summaryrefslogtreecommitdiff
path: root/dev-java/stax-ex/stax-ex-1.0-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/stax-ex/stax-ex-1.0-r5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/stax-ex/stax-ex-1.0-r5.ebuild')
-rw-r--r--dev-java/stax-ex/stax-ex-1.0-r5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/stax-ex/stax-ex-1.0-r5.ebuild b/dev-java/stax-ex/stax-ex-1.0-r5.ebuild
new file mode 100644
index 000000000000..21dc794ee4e0
--- /dev/null
+++ b/dev-java/stax-ex/stax-ex-1.0-r5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Extensions to complement JSR-173 StAX API"
+HOMEPAGE="http://stax-ex.java.net/"
+SRC_URI="https://stax-ex.java.net/files/documents/4480/44372/${P}-src.tar.gz"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~x86-fbsd"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}"
+
+src_prepare() {
+ default
+ rm "${S}"/build.xml || die
+}