summaryrefslogtreecommitdiff
path: root/dev-java/spice-jndikit/spice-jndikit-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/spice-jndikit/spice-jndikit-1.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/spice-jndikit/spice-jndikit-1.4.ebuild')
-rw-r--r--dev-java/spice-jndikit/spice-jndikit-1.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/spice-jndikit/spice-jndikit-1.4.ebuild b/dev-java/spice-jndikit/spice-jndikit-1.4.ebuild
new file mode 100644
index 000000000000..b2557cff7bdc
--- /dev/null
+++ b/dev-java/spice-jndikit/spice-jndikit-1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN##*-}"
+
+DESCRIPTION="JNDI Kit is a toolkit designed to help with the construction of JNDI providers"
+HOMEPAGE="https://github.com/realityforge/jndikit"
+SRC_URI="https://github.com/realityforge/${MY_PN}/archive/${PV}.zip -> ${P}.zip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ rm -rf src/test || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ pushd target/classes > /dev/null || die
+ rmic org.realityforge.spice.jndikit.rmi.server.RMINamingProviderImpl \
+ || die "rmic failed"
+ popd > /dev/null || die
+}