summaryrefslogtreecommitdiff
path: root/dev-java/rat/rat-0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/rat/rat-0.11.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/rat/rat-0.11.ebuild')
-rw-r--r--dev-java/rat/rat-0.11.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-java/rat/rat-0.11.ebuild b/dev-java/rat/rat-0.11.ebuild
deleted file mode 100644
index c5275947926b..000000000000
--- a/dev-java/rat/rat-0.11.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_PN="apache-${PN}"
-
-DESCRIPTION="Apache Rat is a release audit tool, focused on licenses."
-HOMEPAGE="https://creadur.apache.org/rat/"
-
-SRC_URI="
- https://repo1.maven.org/maven2/org/apache/${PN}/${MY_PN}-core/${PV}/${MY_PN}-core-${PV}-sources.jar
- https://repo1.maven.org/maven2/org/apache/${PN}/${MY_PN}-tasks/${PV}/${MY_PN}-tasks-${PV}-sources.jar"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-CDEPEND="
- dev-java/ant-core:0
- dev-java/commons-io:1
- dev-java/commons-cli:1
- dev-java/commons-lang:2.1
- dev-java/commons-compress:0
- dev-java/commons-collections:0
-"
-
-RDEPEND="
- ${CDEPEND}
- >=virtual/jre-1.6"
-
-DEPEND="
- ${CDEPEND}
- app-arch/unzip
- >=virtual/jdk-1.6"
-
-JAVA_GENTOO_CLASSPATH="
- ant-core
- commons-io-1
- commons-cli-1
- commons-compress
- commons-lang-2.1
- commons-collections
-"
-
-src_install() {
- java-pkg-simple_src_install
- java-pkg_dolauncher "${MY_PN}" --main org.apache.rat.Report
-}