summaryrefslogtreecommitdiff
path: root/dev-java/protobuf-java
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
commit3bd85407abc9ed4434c2d3741f84fdb512638b1c (patch)
tree15a296c276aca23d87cb4f2181f2249d706ca05f /dev-java/protobuf-java
parenta90c84e720803f3d26c0ade8f1f1e405ca97502a (diff)
gentoo auto-resync : 14:01:2023 - 23:53:26
Diffstat (limited to 'dev-java/protobuf-java')
-rw-r--r--dev-java/protobuf-java/Manifest1
-rw-r--r--dev-java/protobuf-java/protobuf-java-9999.ebuild109
2 files changed, 0 insertions, 110 deletions
diff --git a/dev-java/protobuf-java/Manifest b/dev-java/protobuf-java/Manifest
index 31be0a21701d..53ca2eb33446 100644
--- a/dev-java/protobuf-java/Manifest
+++ b/dev-java/protobuf-java/Manifest
@@ -4,5 +4,4 @@ DIST truth-1.1.3.jar 243021 BLAKE2B a59149038c62ef5dd352b13d4b393e1b7715fbafe5ed
EBUILD protobuf-java-3.21.12.ebuild 4455 BLAKE2B da8ac403b4db3b9b24b52b797c14e0a0e08a36f10e5dc06a3ef7fe82457e5d0e3df815c701e452257aff7f8ee12d648cfc19c54794d74a53ed7098edb6476012 SHA512 9c0c98c0de93c5d7425c75907bf3c51d968df50fb31cbabeb2733112f76e5341294f2700f7c9cbc9daf006a469448af583c2cbb87ce99e0f5b01d2421d2eaf7d
EBUILD protobuf-java-3.21.9-r1.ebuild 2998 BLAKE2B ccc295705b54c9d132c5d67a5a949fa3cbc9d0ee330540d9824c5e36dc738e70080fdb66a941f225748df62af934b30c2745f01b06436eb6c3e921c04e6c1dcb SHA512 7d11c96dfa448ae46ebab6ddcc0dc622cd8bbc04090354148eaf2d89f6f9d3f31b7b49eae7506e70dc0f78bde3bf4ddf74cdba214a663d47cdaa1466168b0e72
EBUILD protobuf-java-3.21.9-r2.ebuild 4309 BLAKE2B 0d836a8bd93a282e57702ae646eff00983d3f1e037a9bd9267e0a3167c632bf254b83339379b77746d5c11564d8db9827a810623df57aa2a893e8c5e1c25c203 SHA512 73b895c8e096ae863dfc56c948649701721690fa13ba51d15cdfc31a14f4034a82653069caa1d77749f1da4e6e637ac6306bd7157c128bb608cded3dbdf8a448
-EBUILD protobuf-java-9999.ebuild 3078 BLAKE2B 837383cde2c29c4605564b30a071eeb8240c9a447a03cae8c63526d0c0011146faf0a914fe13c0cfe6952f49fef01c08e928fb7568a1f7930393ae851a87f484 SHA512 4be8eef3afd89a5e0248d4181d0ae7e1fdde18adfa9e7e3e9aa869e174adff77ce066ae346393d201ba585c7dd686b7ee0826ba9f76729f11569717b5655441c
MISC metadata.xml 625 BLAKE2B 13394b9a2148b9117ce719954591e79088f845ac1ceb667bbdd2645b989daadcfea09525f9dde68c405e3f1cce5cc1af32de9fb4dff629e4745e13fa92727dd7 SHA512 47f693db57dbde04f419ed65494d81b0a800c9ac49d790c9b794baef34fb1f876da29c5a0662c45aa3c01cecd34af648e196fb76110fcc0066198c59543049b3
diff --git a/dev-java/protobuf-java/protobuf-java-9999.ebuild b/dev-java/protobuf-java/protobuf-java-9999.ebuild
deleted file mode 100644
index f269a7bc8533..000000000000
--- a/dev-java/protobuf-java/protobuf-java-9999.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 2008-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-# Version based on value in (java/)core/pom.xml from main branch
-# Please update me when new release
-# Maybe find a way to automatically change it?
-MAVEN_ID="com.google.protobuf:${PN}:3.21.7"
-# Tests not enabled, depend on com.google.truth which is not packaged
-# https://github.com/protocolbuffers/protobuf/blob/v21.7/java/core/pom.xml#L35-L40
-# JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit edo java-pkg-2 java-pkg-simple
-
-PARENT_PN="${PN/-java/}"
-PARENT_PV="${PV}"
-PARENT_P="${PARENT_PN}-${PARENT_PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
- -> ${PARENT_P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-DESCRIPTION="Google's Protocol Buffers - Java bindings"
-HOMEPAGE="
- https://developers.google.com/protocol-buffers/
-"
-
-LICENSE="BSD"
-SLOT="0/32"
-
-S="${WORKDIR}/${PARENT_P}/java"
-
-BDEPEND="
- dev-libs/protobuf:${SLOT}
-"
-DEPEND="
- >=virtual/jdk-1.8:*
- test? (
- dev-java/guava:0
- dev-java/mockito:4
- )
-"
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-JAVA_AUTOMATIC_MODULE_NAME="com.google.protobuf"
-JAVA_JAR_FILENAME="protobuf.jar"
-JAVA_RESOURCE_DIRS="core/src/main/resources"
-JAVA_SRC_DIR="core/src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="guava,junit-4,mockito-4"
-JAVA_TEST_RESOURCE_DIRS="../src"
-JAVA_TEST_SRC_DIR="core/src/test/java"
-
-# Same than PATCHES but from repository's root directory,
-# please see function `src_prepare` below.
-# Simplier for users IMHO.
-PARENT_PATCHES=(
-)
-
-# Here for patches within "java/" subdirectory.
-PATCHES=(
-)
-
-src_prepare() {
- pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
- [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
- eapply_user
- popd > /dev/null || die
-
- # Remove bundled jars
- java-pkg_clean
-
- java-pkg-2_src_prepare
-
- # There is also compiler/plugin, but not in this list because in a subdirectory
- core_protos=( any api descriptor duration empty field_mask source_context struct timestamp type wrappers )
-
- # Copy resources from ../src/google/protobuf according to
- # https://github.com/protocolbuffers/protobuf/blob/v21.7/java/core/pom.xml#L45-L61
- mkdir -p "${JAVA_RESOURCE_DIRS}/google/protobuf/compiler" || die
- local core_proto
- for core_proto in "${core_protos[@]}"; do
- cp "../src/google/protobuf/${core_proto}.proto" \
- "${JAVA_RESOURCE_DIRS}/google/protobuf" \
- || die
- done
- cp {../src,"${JAVA_RESOURCE_DIRS}"}/google/protobuf/compiler/plugin.proto || die
-
- # Generate 146 .java files according to
- # https://github.com/protocolbuffers/protobuf/blob/v21.7/java/core/generate-sources-build.xml
- for core_proto in "${core_protos[@]}" compiler/plugin; do
- edo "${BROOT}/usr/bin/protoc" \
- --java_out="${JAVA_SRC_DIR}" -I../src ../src/google/protobuf/"${core_proto}".proto
- done
-}