summaryrefslogtreecommitdiff
path: root/dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild')
-rw-r--r--dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild b/dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild
new file mode 100644
index 000000000000..5ef88db0e2f5
--- /dev/null
+++ b/dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Enterprise Release 5 Companion Code"
+SRC_URI="http://www.osgi.org/download/r5/osgi.enterprise-${PV}.jar"
+HOMEPAGE="http://www.osgi.org/Main/HomePage"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RESTRICT="bindist fetch"
+
+CDEPEND="dev-java/glassfish-persistence:0
+ dev-java/osgi-core-api:0
+ java-virtuals/servlet-api:2.5"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+JAVA_GENTOO_CLASSPATH="glassfish-persistence,osgi-core-api,servlet-api-2.5"
+
+pkg_nofetch() {
+ einfo "Please download osgi.enterprise-${PV}.jar from"
+ einfo " http://www.osgi.org/Download/Release5"
+ einfo "which you can find listed as"
+ einfo " OSGi Enterprise Release 5 Companion Code"
+ einfo "after accepting the license."
+}
+
+java_prepare() {
+ rm -r org || die
+}