summaryrefslogtreecommitdiff
path: root/dev-java/osgi-compendium
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-java/osgi-compendium
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-java/osgi-compendium')
-rw-r--r--dev-java/osgi-compendium/Manifest2
-rw-r--r--dev-java/osgi-compendium/osgi-compendium-4.3.1-r3.ebuild (renamed from dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild)22
2 files changed, 9 insertions, 15 deletions
diff --git a/dev-java/osgi-compendium/Manifest b/dev-java/osgi-compendium/Manifest
index b62ca8379727..9531af77db45 100644
--- a/dev-java/osgi-compendium/Manifest
+++ b/dev-java/osgi-compendium/Manifest
@@ -1,3 +1,3 @@
DIST osgi.cmpn-4.3.1.jar 741615 BLAKE2B 6f6058c07fd7744f0369d05cdf607b4d4fe51bbdf567c6a6c951413b0627eb1dbb6e56f65641a8472198d0aedca378da4715c26ebe05aa4e7ef80adb1020175f SHA512 803e929b4b7cfee13a3ffa2c60ad03775afd8409c972bf26e3f79abc590466c2d885bdc339d9af2a3e8fda9cdf082d23a298362ac37935b0ede0719dee27e9f9
-EBUILD osgi-compendium-4.3.1-r2.ebuild 871 BLAKE2B 20f2cd1d7ce730734be4234a1d29cddc5c7c5b99e751d2ae385d13fc2490f48c94452f311b39c9c1610866a9787fc5b4cf918ddd10ffcdffa3f5aec14e0f2878 SHA512 fc9cb03f738d0d95a02a9635b172e4e9b95ed8c6cbb5cfe7f7be313ffd63c664d4863911324512c363acba0217bc8a912800f6262d898d842fb89754cbbccb56
+EBUILD osgi-compendium-4.3.1-r3.ebuild 739 BLAKE2B 83864aadf4daea0a63c24a3bbbec5970f6a6ef80128da9022b0187d347d9c2ef54e8bbda08210c19d9fbff660f46bb84d016236361541aa6fda15bd22e009447 SHA512 3e9758cde8207ee0f141d0d8bfae0831ae7611e004a80be402c9b1537e4be65939937965827cb1cc86657aadfa927a9745113d8db2fe2c0c9833008bb3e61d02
MISC metadata.xml 237 BLAKE2B 7c3263833976c18611a5cba44845af4d80f2f86c48cf587a657292ed0074022088cef88756e3209b292252dce5c0eea307c4f2f45f28b8517609124708f7d09a SHA512 e8227b536eb45569cbf744907106e101d1aa6bf9ba8337783786d719ab107d8bda0fde5dd7067d168181d694b4161b12d1ef3cb5a83b14971b21aa4479670559
diff --git a/dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild b/dev-java/osgi-compendium/osgi-compendium-4.3.1-r3.ebuild
index 609e01017aa2..42efea848da4 100644
--- a/dev-java/osgi-compendium/osgi-compendium-4.3.1-r2.ebuild
+++ b/dev-java/osgi-compendium/osgi-compendium-4.3.1-r3.ebuild
@@ -1,42 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="OSGi Service Platform Compendium API (Companion Code)"
-HOMEPAGE="http://wiki.osgi.org/wiki/Release_4.3"
-SRC_URI="https://osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
+HOMEPAGE="https://docs.osgi.org"
+SRC_URI="https://docs.osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
-LICENSE="Apache-2.0 OSGi-Specification-2.0"
+LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-CDEPEND="dev-java/glassfish-persistence:0
+CP_DEPEND="
+ dev-java/glassfish-persistence:0
dev-java/osgi-core-api:0
dev-java/osgi-foundation:0
dev-java/tomcat-servlet-api:4.0"
-DEPEND="${CDEPEND}
+DEPEND="${CP_DEPEND}
>=virtual/jdk-1.8:*"
-RDEPEND="${CDEPEND}
+RDEPEND="${CP_DEPEND}
>=virtual/jre-1.8:*"
BDEPEND="app-arch/unzip"
JAVA_SRC_DIR="OSGI-OPT/src"
-JAVA_GENTOO_CLASSPATH="
- osgi-core-api
- osgi-foundation
- glassfish-persistence
- tomcat-servlet-api-4.0
-"
-
src_prepare() {
default
rm -r org || die