summaryrefslogtreecommitdiff
path: root/dev-java/openjfx/openjfx-11.0.6_p2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-java/openjfx/openjfx-11.0.6_p2.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-java/openjfx/openjfx-11.0.6_p2.ebuild')
-rw-r--r--dev-java/openjfx/openjfx-11.0.6_p2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-java/openjfx/openjfx-11.0.6_p2.ebuild b/dev-java/openjfx/openjfx-11.0.6_p2.ebuild
index 8132340592e9..23574d61505c 100644
--- a/dev-java/openjfx/openjfx-11.0.6_p2.ebuild
+++ b/dev-java/openjfx/openjfx-11.0.6_p2.ebuild
@@ -7,7 +7,7 @@ MY_PV=${PV/_p/+}
SLOT=${MY_PV%%[.+]*}
EGRADLE_VER="4.8"
-inherit java-pkg-2 multiprocessing
+inherit flag-o-matic java-pkg-2 multiprocessing
DESCRIPTION="Java OpenJFX client application platform"
HOMEPAGE="https://openjfx.io"
@@ -25,7 +25,6 @@ SRC_URI="https://hg.openjdk.java.net/${PN}/${SLOT}-dev/rt/archive/${MY_PV}.tar.b
"
LICENSE="GPL-2-with-classpath-exception"
-SLOT="$(ver_cut 1)"
KEYWORDS="-* ~amd64"
IUSE="cpu_flags_x86_sse2 debug doc source +media"
@@ -168,6 +167,8 @@ src_prepare() {
}
src_configure() {
+ append-flags -Wno-error
+
#FIXME: still calls gcc, pkg-config etc by name without chost prefix
#FIXME: should we enable webkit? doubt so
@@ -193,7 +194,7 @@ src_configure() {
LINT = none
CONF = $(usex debug DebugNative Release)
NUM_COMPILE_THREADS = $(makeopts_jobs)
- JFX_DEPS_URL = "${T}"/jars
+ JFX_DEPS_URL = ${T}/jars
COMPANY_NAME = "Gentoo"
_EOF_
}