summaryrefslogtreecommitdiff
path: root/dev-java/offo-hyphenation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/offo-hyphenation
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/offo-hyphenation')
-rw-r--r--dev-java/offo-hyphenation/Manifest3
-rw-r--r--dev-java/offo-hyphenation/metadata.xml11
-rw-r--r--dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-java/offo-hyphenation/Manifest b/dev-java/offo-hyphenation/Manifest
new file mode 100644
index 000000000000..788178938449
--- /dev/null
+++ b/dev-java/offo-hyphenation/Manifest
@@ -0,0 +1,3 @@
+DIST offo-hyphenation_v2.0.zip 858046 BLAKE2B 193ef92fd55a4c5e8f840d29f96417a725e678e5bd03473ff22a116894b94a40aee8b12ef7a0534020746f21db8304a2840ce09417f2182259c78a03109e63ad SHA512 8a907a38dcb54ef1578973293efa2fcd771e3c77faedd537381f04f6f543b3f04ff8b8f96fb692274e9fe9cbdb2d3d8e5c7b29caae412271d9d8c023c079421b
+EBUILD offo-hyphenation-2.0.ebuild 995 BLAKE2B 754a31b96ed1f845222c98e94198bdd425b341d85d32d07af2d5182e3648c23c57ba444d7225b1f803d881df6d77aab05684af34bb187a92225b8ad6024425ed SHA512 cc62e89925ef5cc9a91652b76639388837ad7b884af805d4e53c92b6bb1b95131182b82bd295658619aa3b537528a0b31da14dc2080cf53ab809a69dcea27cd3
+MISC metadata.xml 310 BLAKE2B 29b282b6cbcd61925f963cd75bfc6cb5f7955593281bda8f327d6afad6762fca4a09e6a1cf4c2aa3abebb8fb323bff23fc1bb0cab5df6229ea62558d0f7c3485 SHA512 1f1c8172b99df046c63f3b23e7a0331954433fa05dfd106b8e97d5f6039635f378714ae49ddaf8b58a4512d3d1789b3df5798570619f5f241bbf564f4c5e6a03
diff --git a/dev-java/offo-hyphenation/metadata.xml b/dev-java/offo-hyphenation/metadata.xml
new file mode 100644
index 000000000000..eb0f3a26bd42
--- /dev/null
+++ b/dev-java/offo-hyphenation/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">offo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild b/dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild
new file mode 100644
index 000000000000..e68c0ee10fa8
--- /dev/null
+++ b/dev-java/offo-hyphenation/offo-hyphenation-2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Hyphenation patterns for Apache Fop"
+HOMEPAGE="http://offo.sourceforge.net"
+SRC_URI="mirror://sourceforge/offo/${PN}_v${PV}.zip"
+LICENSE="GPL-2 Apache-2.0 LPPL-1.3b TeX"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/${PN}/
+ insinto /usr/share/${PN}/
+ doins -r hyph
+
+ if use doc; then
+ dohtml -r images skin i*.html
+ fi
+}
+
+pkg_postinst() {
+ elog "This package installs hyphenation files for several languages"
+ elog "into /usr/share/${PN}/hyph"
+ elog "Check /usr/share/doc/${PF}/html/licenses.html for each file's license."
+ elog "To compile the patterns, install dev-java/fop with USE=hyphenation."
+ elog "Alternatively, use the uncompiled patterns via the <hyphenation-base>"
+ elog "configuration option. See the documentation for more details."
+}