summaryrefslogtreecommitdiff
path: root/dev-java/microba/microba-0.4.4.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/microba/microba-0.4.4.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/microba/microba-0.4.4.3-r1.ebuild')
-rw-r--r--dev-java/microba/microba-0.4.4.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/microba/microba-0.4.4.3-r1.ebuild b/dev-java/microba/microba-0.4.4.3-r1.ebuild
new file mode 100644
index 000000000000..02c622fbcd24
--- /dev/null
+++ b/dev-java/microba/microba-0.4.4.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Swing components for date operations and palettes"
+HOMEPAGE="https://github.com/tdbear/microba"
+SRC_URI="https://github.com/tdbear/${PN}/archive/${PV}.zip -> ${P}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CP_DEPEND="dev-java/jgraph:0"
+
+RDEPEND="${CP_DEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="${CP_DEPEND}
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}"
+JAVA_SRC_DIR="src/main/java"
+
+DOCS=(
+ change.log.txt
+ readme.txt
+ README.md
+)
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar ${JAVA_SRC_DIR}
+}
+
+src_install() {
+ default
+ java-pkg-simple_src_install
+}