summaryrefslogtreecommitdiff
path: root/dev-java/lmax-disruptor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-java/lmax-disruptor
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-java/lmax-disruptor')
-rw-r--r--dev-java/lmax-disruptor/Manifest3
-rw-r--r--dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild41
-rw-r--r--dev-java/lmax-disruptor/metadata.xml11
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/lmax-disruptor/Manifest b/dev-java/lmax-disruptor/Manifest
new file mode 100644
index 000000000000..ac883d4784a9
--- /dev/null
+++ b/dev-java/lmax-disruptor/Manifest
@@ -0,0 +1,3 @@
+DIST lmax-disruptor-3.4.4.tar.gz 237165 BLAKE2B ff17747e24a587e4b0656e16281ecf98cad5b3f260cd270a87e157ccbd6afc4a4e0886fcfab774a3c7919a9f5d26e13199a3cbcd3f7699986d4f9a36576f72dd SHA512 871d474ecbc4e09d33b0d099232f2abdf88b755141e00406e4a721e5bd6c5edc99c6c446277e054bd603ae9b158bdb6b438aa6e8532194dca9bce953b748bfde
+EBUILD lmax-disruptor-3.4.4.ebuild 1107 BLAKE2B 03bcc8f5ffcb179470fdb30b17947d2bc5cb5cd344e1fd2686d1b34240552cd0fb656a4c3b0240f37a0e06d7f4556d2a2eab625eeacab17833924cb6a30e23e8 SHA512 e420a4458140df67c28a9899bec7eb5bc7ac4d50d64c470031dac91c43048f0070064fcae6156c78a5b6fb8af95a3565665c634c4c387a104b3e44700ccc5d3c
+MISC metadata.xml 376 BLAKE2B f4b72884865eb86b976ea321da5928f86381e0e75e3a70e41d021bae09899405a94ed5912e1df50ff08cf5c2235dcd8d4313b28ff28abf2139472d4567c8e371 SHA512 024ef518413831c50007e65121469b9e3b8c1f10e83bb9c43dc7f266163f694d72cccdc1ecaa03f12461dd9f8571049dba95968e22407d662d3e249fff9779af
diff --git a/dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild b/dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild
new file mode 100644
index 000000000000..740ecc7747c2
--- /dev/null
+++ b/dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.lmax:disruptor:3.4.4"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A High Performance Inter-Thread Messaging Library"
+HOMEPAGE="https://lmax-exchange.github.io/disruptor/"
+SRC_URI="https://github.com/LMAX-Exchange/disruptor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( LICENCE.txt README.md )
+
+S="${WORKDIR}/disruptor-${PV}"
+
+JAVA_SRC_DIR="src/main"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test"
+JAVA_TEST_EXCLUDES=(
+ # valid test classes have pattern *Test with nothing behind
+ com.lmax.disruptor.dsl.stubs.TestWorkHandler # No runnable methods
+ com.lmax.disruptor.support.TestEvent # No runnable methods
+ com.lmax.disruptor.support.TestWaiter # No runnable methods
+)
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/lmax-disruptor/metadata.xml b/dev-java/lmax-disruptor/metadata.xml
new file mode 100644
index 000000000000..bc7984dba201
--- /dev/null
+++ b/dev-java/lmax-disruptor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">LMAX-Exchange/disruptor</remote-id>
+ <bugs-to>https://github.com/LMAX-Exchange/disruptor/issues</bugs-to>
+ </upstream>
+</pkgmetadata>