summaryrefslogtreecommitdiff
path: root/dev-java/libg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/libg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/libg')
-rw-r--r--dev-java/libg/Manifest3
-rw-r--r--dev-java/libg/libg-2.1.0-r1.ebuild47
-rw-r--r--dev-java/libg/metadata.xml11
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/libg/Manifest b/dev-java/libg/Manifest
new file mode 100644
index 000000000000..e0ae1ecbf44e
--- /dev/null
+++ b/dev-java/libg/Manifest
@@ -0,0 +1,3 @@
+DIST bndlib-2.1.0.tar.gz 123217291 BLAKE2B ab8e6876b13db538746f77aa1fe7800e5a3b5e539e1980da78f69c64344f4964bf0a21f2329f7684b055d0de39a10c8df36e030922e9933b29fccb9a35aa669a SHA512 6965143ced45c15fc2316716de32e80506cc411d52309b24313fff37e0713a45ad200d5b3701f0d47a131a3163ec266ed8acb4544884cd1c59c9716c7a2b285e
+EBUILD libg-2.1.0-r1.ebuild 1365 BLAKE2B bc2e2bb471a8b427b3200ef39d6ca363ae0faea4ac55f66bd1742ab6bbddadc528897ab51a8d310a3aadd2b51b72c86769d880f7a3046add50938da0cbb091c3 SHA512 34d78f327d082e95c09cacb764b34391311d76b76aeea147ab1488fd781aa4955bc7d6f6baa09ce364953f2b13f424096fc0658b7a974b4adc88b429213ca829
+MISC metadata.xml 323 BLAKE2B b7a6a3bf3330da14a229f4b8e178c7f5da2bdab8d7249b92daa4a6d414471b001d21441465852b21f9abbbb6bdff229a8c7dbe162e4ae820d5feccf2684c19f8 SHA512 b9affc0513759478d6db10968d574cc820ac19476a539d27e279884314805f663f0807abd01ce8107154fae445ad3e4fd37f485004130f04aa890c0607f85fcf
diff --git a/dev-java/libg/libg-2.1.0-r1.ebuild b/dev-java/libg/libg-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..0595fc1a9fc6
--- /dev/null
+++ b/dev-java/libg/libg-2.1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lots of small utilities for bndlib, a swiss army knife for OSGi"
+HOMEPAGE="http://www.aqute.biz/Bnd/Bnd"
+SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# Tests depend on biz.aQute.junit, which depends on biz.aQute.bndlib, which on
+# its own turn again depends on aQute.libg again; we can temporarily assume that
+# if bndlib tests pass that libg is sufficiently tested, in the future we should
+# look whether it is feasible to combine the packages or otherwise temporarily
+# build biz.aquite.bndlib and biz.aqute.junit in this package.
+RESTRICT="test"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/bnd-${PV}.REL/aQute.${PN}"
+
+EANT_BUILD_TARGET="build"
+
+java_prepare() {
+ # Move the correct build.xml into place, needed for testing.
+ cp ../cnf/build.xml . || die "Failed to move build file into the right place."
+
+ # Remove bundled jar files.
+ find . -name '*.jar' -delete
+
+ # Remove test files
+ if ! use test ; then
+ find src/test -name '*.java' -delete || die "Failed to remove test files."
+ fi
+}
+
+src_install() {
+ java-pkg_newjar generated/aQute.${PN}.jar
+}
diff --git a/dev-java/libg/metadata.xml b/dev-java/libg/metadata.xml
new file mode 100644
index 000000000000..7ed2fdf0797a
--- /dev/null
+++ b/dev-java/libg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bndtools/bnd</remote-id>
+ </upstream>
+</pkgmetadata>