summaryrefslogtreecommitdiff
path: root/dev-java/jsr305/jsr305-3.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-java/jsr305/jsr305-3.0.2-r1.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-java/jsr305/jsr305-3.0.2-r1.ebuild')
-rw-r--r--dev-java/jsr305/jsr305-3.0.2-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-java/jsr305/jsr305-3.0.2-r1.ebuild b/dev-java/jsr305/jsr305-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..50cee08b8834
--- /dev/null
+++ b/dev-java/jsr305/jsr305-3.0.2-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Annotations for Software Defect Detection in Java"
+HOMEPAGE="http://jcp.org/en/jsr/detail?id=305"
+SRC_URI="http://central.maven.org/maven2/com/google/code/findbugs/${PN}/${PV}/${P}-sources.jar -> ${P}.jar"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"