summaryrefslogtreecommitdiff
path: root/dev-java/json-smart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-27 22:51:10 +0000
commitee0c4d5e506a6c64994a15c3af5cf1ca22045567 (patch)
treebdf578939023d42f04092ddb4bcd190eb391770f /dev-java/json-smart
parent161eaa4b12ca6314376288834bba20b7824d0d77 (diff)
gentoo auto-resync : 27:11:2023 - 22:51:09
Diffstat (limited to 'dev-java/json-smart')
-rw-r--r--dev-java/json-smart/Manifest4
-rw-r--r--dev-java/json-smart/json-smart-2.5.0.ebuild71
-rw-r--r--dev-java/json-smart/metadata.xml1
3 files changed, 75 insertions, 1 deletions
diff --git a/dev-java/json-smart/Manifest b/dev-java/json-smart/Manifest
index 959ada7a750b..cc44bcbcad93 100644
--- a/dev-java/json-smart/Manifest
+++ b/dev-java/json-smart/Manifest
@@ -1,3 +1,5 @@
DIST json-smart-1.3.3.tar.gz 49430 BLAKE2B 805e16e0de5321a2e8164468757e9b722849f0fe90fd6822cc99f7afffd9f4e480fc4e14c2bbd12b325a27abc8ca7e93b4a17ce56ac352117cef336e1ebb3fe9 SHA512 c6006c6a00a085ea8810e18889450d11240dc3671351f20602214db418107808df1f413fe67c199d6529e4c0087f2533601826666ac4fa493bcaf72d2c18ed83
+DIST json-smart-2.5.0.tar.gz 88839 BLAKE2B 25760bd9c9ddecfef2fc3e60fc28b83def2223c7fc1e52ef39b3e6d01e5f2f29f36a35bfd43fc4d6ce6d5df5fcb25f59b1c86e1864a3044c69a6d0010335280b SHA512 4bffadf68998da4b63b34bcc9dbf804fd2b21b8d9514de4e155127d5a2eb3db74c7e396959b54c61c08e169eeed85dff3ad2f1d899cfddca53e501c45cebae21
EBUILD json-smart-1.3.3.ebuild 677 BLAKE2B 089132dec7953a4be817a978d8c858e4bc795781235f280c687cbb2f77e30ab7e0d48cb3899e5f69bc68d916adbc29563202d5c8dc84b7fc31f6a72ea7dba288 SHA512 db7c3ae30ca5a871aab7ee28e898cfdef844e395bae3b35621ae79fa2b3485d0f694635efeb507fd03ebce679dbbec87e6f938b88f1b459f3e86a3a9eb6d4cc2
-MISC metadata.xml 581 BLAKE2B cb4940f8ccd37d65394767bb34d8bbc8b6894c04cce7c414a7aa999f970315dda859a9d44a99cf64bb808910d7e48f11807d3dc495e0b74f85bfe727889d257d SHA512 19ffaef2fcf62e7ce10bbd689d935d41a74ffbbc528255740dced2a63cf4748de4f4f337d7c974404a746936e1db7e96520952b6edad42405b013bed649f2716
+EBUILD json-smart-2.5.0.ebuild 1633 BLAKE2B 93a8d99d0c5c2dc7cbbc65e0c4f0bff46948ca48e5aae496703dee4d010f9cdd4f57c0194351f2a650c2f2414e75d2c716e696eaf47ccec73c8d5b55c8349ecd SHA512 b0d3e4bc422a1e95296334e8867b0a7b259cbfb019c526ca7856534e1a4eb3fc372887abc8de340cc8ef2356d4a0da558e13be8a9fe0d867d5f6511c2fdc0cfd
+MISC metadata.xml 642 BLAKE2B c365803a643b02f870ff0658d1184c227a243f1d9801ddfa9f5c487412f390a4714b75f461ad5b4acf589da5f0201df19e10126c5ccd2a2685c77edd5c774765 SHA512 f28271bf046bdcec40f7c8fa824d8eaf0d222c082412c08f9e9f3a766769d8c5c29e32cb4136f0722ae4400ce9fbf28776880c0d10903ccabe2a1d6953cee3ac
diff --git a/dev-java/json-smart/json-smart-2.5.0.ebuild b/dev-java/json-smart/json-smart-2.5.0.ebuild
new file mode 100644
index 000000000000..bed1dc2846b3
--- /dev/null
+++ b/dev-java/json-smart/json-smart-2.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_PROVIDES="
+ net.minidev:accessors-smart:${PV}
+ net.minidev:json-smart:${PV}
+"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JSON Small and Fast Parser"
+HOMEPAGE="https://urielch.github.io"
+SRC_URI="https://github.com/netplex/json-smart-v2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-v2-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+RESTRICT="test" #839681
+
+DEPEND="
+ dev-java/asm:9
+ >=virtual/jdk-1.8:*
+"
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_compile() {
+ einfo "Compiling accessors-smart.jar"
+ JAVA_CLASSPATH_EXTRA="asm-9"
+ JAVA_JAR_FILENAME="accessors-smart.jar"
+ JAVA_SRC_DIR="accessors-smart/src/main/java"
+ java-pkg-simple_src_compile
+ JAVA_GENTOO_CLASSPATH_EXTRA+=":accessors-smart.jar"
+ rm -r target || die
+
+ einfo "Compiling json-smart.jar"
+ JAVA_JAR_FILENAME="json-smart.jar"
+ JAVA_SRC_DIR="json-smart/src/main/java"
+ java-pkg-simple_src_compile
+ JAVA_GENTOO_CLASSPATH_EXTRA+=":json-smart.jar"
+ rm -r target || die
+
+ if use doc; then
+ einfo "Compiling javadocs"
+ JAVA_SRC_DIR=(
+ accessors-smart/src/main/java
+ json-smart/src/main/java
+ )
+ JAVA_JAR_FILENAME="ignoreme.jar"
+ java-pkg-simple_src_compile
+ fi
+}
+
+src_install() {
+ einstalldocs
+ java-pkg_dojar "accessors-smart.jar"
+ java-pkg_dojar "json-smart.jar"
+
+ if use doc; then
+ java-pkg_dojavadoc target/api
+ fi
+
+ if use source; then
+ java-pkg_dosrc "accessors-smart/src/main/java/*"
+ java-pkg_dosrc "json-smart/src/main/java/*"
+ fi
+}
diff --git a/dev-java/json-smart/metadata.xml b/dev-java/json-smart/metadata.xml
index 4edced72dcda..d5b2471c532c 100644
--- a/dev-java/json-smart/metadata.xml
+++ b/dev-java/json-smart/metadata.xml
@@ -15,5 +15,6 @@
</maintainer>
<upstream>
<remote-id type="github">netplex/json-smart-v1</remote-id>
+ <remote-id type="github">netplex/json-smart-v2</remote-id>
</upstream>
</pkgmetadata>