summaryrefslogtreecommitdiff
path: root/dev-java/json-simple
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /dev-java/json-simple
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'dev-java/json-simple')
-rw-r--r--dev-java/json-simple/Manifest1
-rw-r--r--dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-java/json-simple/Manifest b/dev-java/json-simple/Manifest
index fd9eca740d27..7170972d1a20 100644
--- a/dev-java/json-simple/Manifest
+++ b/dev-java/json-simple/Manifest
@@ -1,4 +1,3 @@
-AUX json-simple-1.1-extra-constructors-from-azureus.patch 1943 BLAKE2B 61ae7ffc7ab463eb6375395447318c3d07695f50f4b7fb288855479a4c20ee49e946dc8016000cb93dd7de7615a69749065fcb0edcd5f1351dc5c72d232a6018 SHA512 603d6f580e4e546a0eb230b521416b7d5409ec896359f4ccf5755adf79bd666da9cb0b1496b58439323b1c8cc18ebf5f550e3c1fd4894ba85b89aa2854584380
DIST json-simple-1.1.tar.gz 22154 BLAKE2B 594717df45d56b4e70cee9aadca661a9da7e19c2a77e5ab2176396c48bdf061f25db0e4cbf5b93b12dc862dfca593a71dcd154f24c914a4d2ff510e3f4b11570 SHA512 f09cb298254a8f35b534670d6a1801eeaf58385529f459f413aed556df1ac577bea6e678a32065077abc851dc310b3af38b818f1737bd255f05e756d7e2da066
EBUILD json-simple-1.1-r1.ebuild 591 BLAKE2B 5dd45bf8dead68b43cd9c28a2a55ad9e13a46d14956edb95b6560d6f0c07b4c960a55b71ddff8fe99898fe812272b01ee7b8bb27dcc468234afbdee964b0a846 SHA512 e1f5bfaa2d7ae6cb525cd1c129d10661e62a702362f3a6ad8977c409094feab9d90be0268b50050310665003e4dc6d4defa60a01655300b2db1028d792c52ac8
MISC metadata.xml 884 BLAKE2B 93c8109aa04543cfda3354252a56ffd6520106daae5eaca5c428e6a001a8b2d87a3ce3d416c70fb06fb28e22f2b399be0d0911ee59856a9feaa26614f39c0ef5 SHA512 c62d038f6913bb8beb903930ed6d354c89b9b5fa231d9096690d263ee35812aad52696a3d15d74c83d99c02392f5ed3ab997bc6e9d2532cbb4ea12cbaab1ebe9
diff --git a/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch b/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch
deleted file mode 100644
index 5b45a973e41d..000000000000
--- a/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -Nur json_simple-1.1-all/src/org/json/simple/JSONArray.java json_simple-1.1-all_patched//src/org/json/simple/JSONArray.java
---- json_simple-1.1-all/src/org/json/simple/JSONArray.java 2009-02-01 12:45:34.000000000 +0200
-+++ json_simple-1.1-all_patched//src/org/json/simple/JSONArray.java 2011-09-25 11:23:37.398818358 +0300
-@@ -19,6 +19,18 @@
- public class JSONArray extends ArrayList implements List, JSONAware, JSONStreamAware {
- private static final long serialVersionUID = 3957988303675231981L;
-
-+ public JSONArray() {
-+ super();
-+ }
-+
-+ public JSONArray(java.util.Collection arg0) {
-+ super(arg0);
-+ }
-+
-+ public JSONArray(int initialCapacity) {
-+ super(initialCapacity);
-+ }
-+
- /**
- * Encode a list into JSON text and write it to out.
- * If this list is also a JSONStreamAware or a JSONAware, JSONStreamAware and JSONAware specific behaviours will be ignored at this top level.
-diff -Nur json_simple-1.1-all/src/org/json/simple/JSONObject.java json_simple-1.1-all_patched//src/org/json/simple/JSONObject.java
---- json_simple-1.1-all/src/org/json/simple/JSONObject.java 2009-02-01 12:45:34.000000000 +0200
-+++ json_simple-1.1-all_patched//src/org/json/simple/JSONObject.java 2011-09-25 11:24:34.815103065 +0300
-@@ -18,6 +18,22 @@
- public class JSONObject extends HashMap implements Map, JSONAware, JSONStreamAware{
- private static final long serialVersionUID = -503443796854799292L;
-
-+ public JSONObject() {
-+ super();
-+ }
-+
-+ public JSONObject(int initialCapacity, float loadFactor) {
-+ super(initialCapacity, loadFactor);
-+ }
-+
-+ public JSONObject(int initialCapacity) {
-+ super(initialCapacity);
-+ }
-+
-+ public JSONObject(Map arg0) {
-+ super(arg0);
-+ }
-+
- /**
- * Encode a map into JSON text and write it to out.
- * If this map is also a JSONAware or JSONStreamAware, JSONAware or JSONStreamAware specific behaviours will be ignored at this top level.