summaryrefslogtreecommitdiff
path: root/dev-java/joni/joni-2.1.41.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/joni/joni-2.1.41.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/joni/joni-2.1.41.ebuild')
-rw-r--r--dev-java/joni/joni-2.1.41.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/joni/joni-2.1.41.ebuild b/dev-java/joni/joni-2.1.41.ebuild
new file mode 100644
index 000000000000..65d03d06022a
--- /dev/null
+++ b/dev-java/joni/joni-2.1.41.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jruby/joni/archive/refs/tags/joni-2.1.41.tar.gz --slot 2.1 --keywords "~amd64 ~ppc64 ~x86" --ebuild joni-2.1.41.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.jruby.joni:joni:2.1.41"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java port of the Oniguruma regular expression engine"
+HOMEPAGE="https://github.com/jruby/joni"
+SRC_URI="https://github.com/jruby/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# org.jruby.jcodings:jcodings:1.0.55 -> >=dev-java/jcodings-1.0.55:1
+
+CDEPEND="
+ dev-java/jcodings:1
+"
+
+DEPEND="
+ >=virtual/jdk-11:*
+ ${CDEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-11:*
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_GENTOO_CLASSPATH="jcodings-1"
+JAVA_SRC_DIR="src"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="test"