summaryrefslogtreecommitdiff
path: root/dev-java/joni/joni-2.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/joni/joni-2.1.0-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/joni/joni-2.1.0-r1.ebuild')
-rw-r--r--dev-java/joni/joni-2.1.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/joni/joni-2.1.0-r1.ebuild b/dev-java/joni/joni-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..cf7f00117692
--- /dev/null
+++ b/dev-java/joni/joni-2.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java port of the Oniguruma regular expression engine"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+CDEPEND="dev-java/asm:9
+ dev-java/jcodings:1"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="asm-9 jcodings-1"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use source && java-pkg_dosrc src/*
+}