summaryrefslogtreecommitdiff
path: root/dev-java/joda-time
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/joda-time
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/joda-time')
-rw-r--r--dev-java/joda-time/Manifest4
-rw-r--r--dev-java/joda-time/files/joda-time-2.7-build.xml262
-rw-r--r--dev-java/joda-time/joda-time-2.7.ebuild59
-rw-r--r--dev-java/joda-time/metadata.xml12
4 files changed, 337 insertions, 0 deletions
diff --git a/dev-java/joda-time/Manifest b/dev-java/joda-time/Manifest
new file mode 100644
index 000000000000..745399b0bca2
--- /dev/null
+++ b/dev-java/joda-time/Manifest
@@ -0,0 +1,4 @@
+AUX joda-time-2.7-build.xml 11231 BLAKE2B 9b7350270773c59f3497be28581408f9984f1151b812f3ddc4bbf8fbfe50505e36cb5fdbfc330f7f07416275adc92a8176b25d7c4cb4cecbdc9d239f711bc9e7 SHA512 c614cc2425b0cefdc5f9def196cd5014d6d65552038dd22f876bbb64ee25131ead57aa94ef967491e292cf1ddefef933d9827dd588056d58c9a311640a5af63f
+DIST joda-time-2.7-dist.tar.gz 4007765 BLAKE2B ed34c988dae1f1fb3359e06cccc148f680a04244987464770024635e72d5693036ec4d1648245f44db2fd57c47d9842a964d39e04e9ba510ecda7ec25c853ee7 SHA512 2a9bf91024bf20c4f1a28c87e5c6e560994ba6f7e131757c83a5ab6984ea79549e1d00452dcf767fc5cab374e531649759703acbaed724a1e49436cae0799209
+EBUILD joda-time-2.7.ebuild 1913 BLAKE2B 9f71d9c32855236f04435433b851dbe582e823dcb0727fc4e71a15ee749f6e7d46e5408bc274213f3934a0f7238b8deee9919f7faa3d4ceb656b58e96dbcee9c SHA512 ad90a7ca92d6e5f0514e9d1a6cb5693240395d470fbf5d59b5bba7678fc2ff679a0e538db638c259b92c160501519105ae3663977681a376b15b989d28b8ab38
+MISC metadata.xml 384 BLAKE2B 298d00eca8bdd34de1a3c30a423051cd62923963b1d239640690cf12c3ddbbe661bfaa689f1b225a968747bcc7d3b28aa53ccd90fa406322aeaa3e1f3703f4a6 SHA512 441aa3d5876d8ff91b9f9d368e817bf6869266c27f7f8686e9eb47812f899f37c5fa2e65337e979dd3247932b61d84e4b4f0d7325ea2659d54221ab428c9c089
diff --git a/dev-java/joda-time/files/joda-time-2.7-build.xml b/dev-java/joda-time/files/joda-time-2.7-build.xml
new file mode 100644
index 000000000000..fa1fd5e25a39
--- /dev/null
+++ b/dev-java/joda-time/files/joda-time-2.7-build.xml
@@ -0,0 +1,262 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 3/22/15 5:59 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="joda-time-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="joda-time-2.7"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.resourceDir.1" value="src/main/java"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/joda/joda-convert/1.2/joda-convert-1.2.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/joda/joda-convert/1.2/joda-convert-1.2.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="false"
+ target="1.5"
+ verbose="true"
+ fork="true"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="LICENSE.txt"/>
+ <include name="NOTICE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="false"
+ target="1.5"
+ verbose="true"
+ fork="true"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/TestAllPackages.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ <group title="User packages"/>
+ <group title="Implementation packages"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/joda/joda-convert/1.2"/>
+ <get src="https://repo.maven.apache.org/maven2/org/joda/joda-convert/1.2/joda-convert-1.2.jar"
+ dest="${maven.repo.local}/org/joda/joda-convert/1.2/joda-convert-1.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/3.8.2"/>
+ <get src="https://repo.maven.apache.org/maven2/junit/junit/3.8.2/junit-3.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/3.8.2/junit-3.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/joda-time/joda-time-2.7.ebuild b/dev-java/joda-time/joda-time-2.7.ebuild
new file mode 100644
index 000000000000..fbf0a92b476f
--- /dev/null
+++ b/dev-java/joda-time/joda-time-2.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+JAVA_PKG_IUSE="doc examples source test"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A quality open-source replacement for the Java Date and Time classes"
+HOMEPAGE="http://www.joda.org/joda-time/ https://github.com/JodaOrg/joda-time/"
+SRC_URI="https://github.com/JodaOrg/${PN}/releases/download/v${PV}/${P}-dist.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RESTRICT="test"
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/joda-convert:0
+ test? (
+ dev-java/junit:0
+ dev-java/ant-junit:0
+ )"
+RDEPEND=">=virtual/jre-1.5"
+
+java_prepare() {
+ rm -v *.jar || die "Failed to remove bundled jars."
+ cp "${FILESDIR}"/${P}-build.xml "${S}"/build.xml || die "Failed to copy build file."
+
+ mkdir -p "${S}"/target/classes || die "Failed to create target classes directory."
+ cp -Rv "${S}"/src/tz-data/* "${S}"/target/classes/ || die "Failed to copy timezone data."
+
+ mkdir -p "${S}"/target/classes/org/joda/time/format || die "Failed to create target classes subdirectory."
+ cp -Rv "${S}"/src/main/java/org/joda/time/format/*properties "${S}"/target/classes/org/joda/time/format/ || die "Failed to copy message bundles."
+}
+
+src_compile() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only joda-convert joda-convert.jar)"
+
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only joda-convert joda-convert.jar):$(java-pkg_getjar --build-only junit junit.jar)"
+
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ dodoc NOTICE.txt RELEASE-NOTES.txt
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use examples && java-pkg_doexamples src/example
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/joda-time/metadata.xml b/dev-java/joda-time/metadata.xml
new file mode 100644
index 000000000000..78620eff5573
--- /dev/null
+++ b/dev-java/joda-time/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">JodaOrg/joda-time</remote-id>
+ <remote-id type="sourceforge">joda-time</remote-id>
+ </upstream>
+</pkgmetadata>