summaryrefslogtreecommitdiff
path: root/dev-java/joda-convert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/joda-convert
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/joda-convert')
-rw-r--r--dev-java/joda-convert/Manifest4
-rw-r--r--dev-java/joda-convert/files/joda-convert-1.3.1-build.xml248
-rw-r--r--dev-java/joda-convert/joda-convert-1.3.1.ebuild42
-rw-r--r--dev-java/joda-convert/metadata.xml11
4 files changed, 305 insertions, 0 deletions
diff --git a/dev-java/joda-convert/Manifest b/dev-java/joda-convert/Manifest
new file mode 100644
index 000000000000..e1f7adcf6ee1
--- /dev/null
+++ b/dev-java/joda-convert/Manifest
@@ -0,0 +1,4 @@
+AUX joda-convert-1.3.1-build.xml 10459 BLAKE2B 79f7930f5d71e046a5e0ad8e4b7bbddb10ce2be67e6d4120685e640d51d201289e02a45bf37a5c295add8cc90404c74c06709b996a946f88b4b2c7a0467c7cb2 SHA512 cfeec9e9ee537814eaa3277037e45878a71b80cd73705bce560cf24d1c0d20033dadd030dcc447b1be5ad742fa97637f57931cab96ca7e21d6b79c7897d7f0ce
+DIST joda-convert-1.3.1-dist.tar.gz 131288 BLAKE2B 0b7b6cebb7e13e89d838ec10c4edd54b52bf3449b3003cd41ea2628719b8ea52bc00a8681a96fad0de79b4acd56fc4a8d4a31d558841fa268d9ffbeb97ca1ed0 SHA512 ee3f7264e9ee445dd8cf088c862809faceb012d317c4974d2312e1ce9b580193096259978a79cdefc2217818600ff38569348625986e19bdb753edb03ba58451
+EBUILD joda-convert-1.3.1.ebuild 929 BLAKE2B cd065e0ba99aa5d4fb8a4bfff03ffc9a202ed97497851032eb3d8a7316b29143034d9a8a04e303b6e3e5027e9c40470642e82c3d24933b681ed84020568bb6fe SHA512 ab4fa2ac52ed7e70a1874ff7ae23eb98561669ccdfcaff994ba447cdca92c101d8e4c493a9a9bf3f78cef4c3271deb2dba93839d279e4694f0df60edd1924334
+MISC metadata.xml 318 BLAKE2B 2222c7e9955b61b5a3369476bfdaa1087b8381846f325d3218768a672b594d64cadc6998d13012653c89df816133be237f97c9f1b2949712c4f120cd107c0a15 SHA512 13ce055f2cf64b4b5f7f6b780c98cfae6bcae0792d5bee30633cb465ab49045fc77da1337042d672bcb1c74cb3a1dc0e26b1d6c5e38f17d3a79152b423a97030
diff --git a/dev-java/joda-convert/files/joda-convert-1.3.1-build.xml b/dev-java/joda-convert/files/joda-convert-1.3.1-build.xml
new file mode 100644
index 000000000000..c66dfec9c1d7
--- /dev/null
+++ b/dev-java/joda-convert/files/joda-convert-1.3.1-build.xml
@@ -0,0 +1,248 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/9/13 4:18 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="joda-convert-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="joda-convert-1.3.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.5/junit-4.5.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="false"
+ target="1.6"
+ verbose="true"
+ fork="true"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="LICENSE.txt"/>
+ <include name="NOTICE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="false"
+ target="1.6"
+ verbose="true"
+ fork="true"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/6/docs/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="src/conf/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.5"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.5/junit-4.5.jar"
+ dest="${maven.repo.local}/junit/junit/4.5/junit-4.5.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/joda-convert/joda-convert-1.3.1.ebuild b/dev-java/joda-convert/joda-convert-1.3.1.ebuild
new file mode 100644
index 000000000000..5ea26cf25cdc
--- /dev/null
+++ b/dev-java/joda-convert/joda-convert-1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java library for conversion between Object and String"
+HOMEPAGE="http://www.joda.org/joda-convert/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-dist.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ppc64"
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/junit:4
+ dev-java/ant-junit:0
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+ dodoc NOTICE.txt RELEASE-NOTES.txt
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/joda-convert/metadata.xml b/dev-java/joda-convert/metadata.xml
new file mode 100644
index 000000000000..50873a696170
--- /dev/null
+++ b/dev-java/joda-convert/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">joda-convert</remote-id>
+ </upstream>
+</pkgmetadata>