summaryrefslogtreecommitdiff
path: root/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild')
-rw-r--r--dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..93852c012269
--- /dev/null
+++ b/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="looks"
+MY_PV="${PV//./_}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Looks Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="2.0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/jdk-1.4
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# bug #150970
+EANT_FILTER_COMPILER="jikes"
+# jar target fails unless we make descriptors.dir an existing directory
+# update: it's where it looks for all.txt file
+EANT_EXTRA_ARGS="-Ddescriptors.dir=\"${S}\""
+
+EANT_BUILD_TARGET="jar-all"
+
+java_prepare() {
+ # remove the bootclasspath brokedness, make building demo optional
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ # unzip the look&feel settings from bundled jar before we delete it
+ unzip -j looks-${PV}.jar META-INF/services/javax.swing.LookAndFeel \
+ || die "unzip of javax.swing.LookAndFeel failed"
+ # and rename it to what build.xml expects
+ mv javax.swing.LookAndFeel all.txt || die
+
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg_dojar build/looks.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ dohtml README.html || die
+ use doc && java-pkg_dojavadoc build/docs/api
+ use source && java-pkg_dosrc src/core/com
+ use examples && java-pkg_doexamples src/demo
+}