summaryrefslogtreecommitdiff
path: root/dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild')
-rw-r--r--dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild b/dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild
new file mode 100644
index 000000000000..fc01183201ac
--- /dev/null
+++ b/dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="forms"
+MY_PV=${PV//./_}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Forms Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/jgoodies-common:${SLOT}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}"/${P}
+
+JAVA_SRC_DIR="src"
+JAVA_GENTOO_CLASSPATH="jgoodies-common-${SLOT}"
+
+java_prepare() {
+ mkdir src || die
+ unzip ${P}-sources.jar -d src || die
+ rm "${S}"/pom.xml "${S}"/*.jar || die
+}