summaryrefslogtreecommitdiff
path: root/dev-java/jgoodies-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jgoodies-common
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jgoodies-common')
-rw-r--r--dev-java/jgoodies-common/Manifest3
-rw-r--r--dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild39
-rw-r--r--dev-java/jgoodies-common/metadata.xml8
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/jgoodies-common/Manifest b/dev-java/jgoodies-common/Manifest
new file mode 100644
index 000000000000..1fc7fae1dfa3
--- /dev/null
+++ b/dev-java/jgoodies-common/Manifest
@@ -0,0 +1,3 @@
+DIST jgoodies-common-1_8_0.zip 575972 BLAKE2B c197f35e495c7f638f9601aa29041271522c8382b97151ea3a4f78a38a17e8dd45d0b6baf8d74bfa0ac3deeefac77c8da3cc8c956495d3443e87461e876e66bc SHA512 c00ffb6498b40b214bccad3ee8f0f3a9231bb8e67243be5ea15956694466485ac75aeed09f340aea323c6989190c10015b7a72b82d5a251bb5ea12ddaedb6b25
+EBUILD jgoodies-common-1.8.0.ebuild 688 BLAKE2B ef68362ebe56fb5b9daa2f4d8081f41425952ca33650b3bb5041c4301a47eb836906673f8849c4637e02cd2d9c55639664439a3beefa69f32e0a0e9a882a3c0e SHA512 c2c9f27c3d8b37fe5bb6679849ba8d8576d9f5b6ab9817b64d09f7a0ce4ca33fd15266dcf7e8dce6d7ead1d86e4e77b8fdf669ed8049be7a13b5743de14218f6
+MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild b/dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild
new file mode 100644
index 000000000000..da63d80e25a4
--- /dev/null
+++ b/dev-java/jgoodies-common/jgoodies-common-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="common"
+MY_PV=${PV//./_}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Common Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND=">=virtual/jre-1.6"
+
+DEPEND="
+ app-arch/unzip
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}"/${P}
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ mkdir src || die
+ unzip ${P}-sources.jar -d src || die
+ rm "${S}"/pom.xml "${S}"/*.jar || die
+}
diff --git a/dev-java/jgoodies-common/metadata.xml b/dev-java/jgoodies-common/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/jgoodies-common/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>