summaryrefslogtreecommitdiff
path: root/dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild')
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild
new file mode 100644
index 000000000000..2fefc655acf5
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.6.8-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CDEPEND="dev-java/log4j:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${PN}"
+
+JAVA_ENCODING="ISO-8859-1"
+JAVA_SRC_DIR="src"
+JAVA_GENTOO_CLASSPATH="log4j"
+
+JAVA_RM_FILES=(
+ src/common/log/Log4jLoggerName.java
+ src/common/log/SimpleLoggerName.java
+)
+
+java_prepare() {
+ java-pkg_clean
+}