summaryrefslogtreecommitdiff
path: root/dev-java/jettison/jettison-1.3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jettison/jettison-1.3.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jettison/jettison-1.3.7.ebuild')
-rw-r--r--dev-java/jettison/jettison-1.3.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/jettison/jettison-1.3.7.ebuild b/dev-java/jettison/jettison-1.3.7.ebuild
new file mode 100644
index 000000000000..c02d303d2230
--- /dev/null
+++ b/dev-java/jettison/jettison-1.3.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A JSON StAX implementation"
+HOMEPAGE="https://github.com/codehaus/jettison"
+SRC_URI="https://github.com/codehaus/${PN}/archive/${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.6"
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/junit:4
+ dev-java/wstx:3.2 )"
+
+S="${WORKDIR}/${PN}-${P}"
+JAVA_SRC_DIR="${S}/src/main/java"
+
+src_test() {
+ cd src/test/java || die
+ local CP=".:${S}/${PN}.jar:$(java-pkg_getjars junit-4,wstx-3.2)"
+
+ local TESTS=$(find * -name "*Test.java" ! -name "DOMTest.java")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -classpath "${CP}" $(find -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}