summaryrefslogtreecommitdiff
path: root/dev-java/jebl/jebl-2013.02.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/jebl/jebl-2013.02.18.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/jebl/jebl-2013.02.18.ebuild')
-rw-r--r--dev-java/jebl/jebl-2013.02.18.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jebl/jebl-2013.02.18.ebuild b/dev-java/jebl/jebl-2013.02.18.ebuild
new file mode 100644
index 000000000000..63fb36ae0fed
--- /dev/null
+++ b/dev-java/jebl/jebl-2013.02.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="doc"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Evolutionary Biology Library"
+HOMEPAGE="http://jebl.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+EANT_BUILD_TARGET="dist"
+EANT_DOC_TARGET="document"
+
+java_prepare() {
+ rm -rf "${S}/src/org/virion/jam/maconly" || die
+}
+
+src_install() {
+ java-pkg_dojar dist/jebl.jar || die
+ java-pkg_dojar dist/jam.jar || die
+ use doc && java-pkg_dojavadoc doc/api
+}