summaryrefslogtreecommitdiff
path: root/dev-java/jcodings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jcodings
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jcodings')
-rw-r--r--dev-java/jcodings/Manifest6
-rw-r--r--dev-java/jcodings/files/maven-build.xml176
-rw-r--r--dev-java/jcodings/jcodings-1.0.11.ebuild40
-rw-r--r--dev-java/jcodings/jcodings-1.0.5.ebuild36
-rw-r--r--dev-java/jcodings/metadata.xml11
5 files changed, 269 insertions, 0 deletions
diff --git a/dev-java/jcodings/Manifest b/dev-java/jcodings/Manifest
new file mode 100644
index 000000000000..b5bfd2841668
--- /dev/null
+++ b/dev-java/jcodings/Manifest
@@ -0,0 +1,6 @@
+AUX maven-build.xml 7254 BLAKE2B 1004cdec7ec80a02f2a0344d748ec0e17e9902be72ea93ac39542b3cc0e8eacd5d95dfc716d5acd20124b9c71aaee2b99bf4bec084301f53897da52758071900 SHA512 0735062e262c9abcb3649ef48d87a9d7489d0d980ee9c77c1e7b6aff4f386344d423403dc54e4d1ae08606adbe1ffea4ac4cf531d4cf1cb2dcf21f1ab95571ad
+DIST jcodings-1.0.11.tar.gz 123802 BLAKE2B 22cde3714da0f1b9434d630905d9a5a8bcdf7ebcab8de5b03ff12d6b31d6fd256f87680743d96e860cd5af34a0b5e70bb1a326000b5440d9b4c4f8a20d9964ee SHA512 6bff29718ff04fd2f52cff767440d87f3dcb0f4acf71ee7b037241af7ef7533284176f53d08da5b1f37c643b766f4a9113651c994d1893ef302a2056d9ff40f3
+DIST jcodings-1.0.5-git.tar.gz 90788 BLAKE2B f1a72a1879e89c60bbb1537d5a6dd174b9f0a2bb4a3eb80520a2b4f7ddae5da359f11ba220b4f64db0413fd423c31623a0863cedbf62f7efd83ce73952557b35 SHA512 a0122eea18077daefdcf38ec9e6f12b000c558837835fe900f6e0c282fdfcf95dbb10652b4cfeb32e556ae8ebe1aec8c10e4a352cdb565837b2f16335140f8e3
+EBUILD jcodings-1.0.11.ebuild 828 BLAKE2B 555aa132da6212e4c772b3500ddfb54e584afc004c2082716defabee2af6d4c9cf4721e5e28c4b3daf9a91715462829828ff14fadda3aefec5257b461cdc27a7 SHA512 f4495874eda08d74cb2639c5a584ef789344d54a3ea6684d96c15df960ef54fb155d3a2ad7ad342d495435e406931550a63f69dd3dafbe51af333a85a5b4ea9c
+EBUILD jcodings-1.0.5.ebuild 763 BLAKE2B cb9ea59e1101e31c8e5f6fdaa9093dd2fb6bbbbdcffa7506ce10968d9a90b346145f56ffd863ad770a3698eb06fdd9128999a702cfa093b59ae041b089439e98 SHA512 bda1b75cbfef5252d46fa1f927775727fd73c306c62e6c2095a5cbbe4a39c9acf318fd0added610fb29c2d39fee198eb3a856fe500aef8199e13c80f5fc435e8
+MISC metadata.xml 325 BLAKE2B ffc57bb511b07c41330a25a5fbc924232362e45c3206c32e7c3d90cd624a9a2b0cd1e5499b510b19387c5eb43134b01bf501b112964beb629d1f1b0b0e6a3abe SHA512 b0a431f148289e90b6bbf25940157336603658375d13d4a256e224174ddeedac53e6dd625239e51763b467678090a6305463c4c89fd878027ca8c4b369434095
diff --git a/dev-java/jcodings/files/maven-build.xml b/dev-java/jcodings/files/maven-build.xml
new file mode 100644
index 000000000000..c09847a4fa00
--- /dev/null
+++ b/dev-java/jcodings/files/maven-build.xml
@@ -0,0 +1,176 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="jcodings-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jcodings"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="test"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ </target>
+
+</project>
diff --git a/dev-java/jcodings/jcodings-1.0.11.ebuild b/dev-java/jcodings/jcodings-1.0.11.ebuild
new file mode 100644
index 000000000000..0800cfad7b1d
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Byte-based encoding support library for Java"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit:0
+ >=dev-java/junit-4.8:4
+ )"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+java_prepare() {
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jcodings/jcodings-1.0.5.ebuild b/dev-java/jcodings/jcodings-1.0.5.ebuild
new file mode 100644
index 000000000000..3d8343932380
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Byte-based encoding support library for Java"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+src_unpack() {
+ default
+ mv jruby-${PN}-* ${P} || die
+}
+
+java_prepare() {
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jcodings/metadata.xml b/dev-java/jcodings/metadata.xml
new file mode 100644
index 000000000000..0214918aa8e0
--- /dev/null
+++ b/dev-java/jcodings/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jruby/jcodings</remote-id>
+ </upstream>
+</pkgmetadata>