summaryrefslogtreecommitdiff
path: root/dev-java/jcodings/jcodings-1.0.55.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/jcodings/jcodings-1.0.55.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/jcodings/jcodings-1.0.55.ebuild')
-rw-r--r--dev-java/jcodings/jcodings-1.0.55.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/jcodings/jcodings-1.0.55.ebuild b/dev-java/jcodings/jcodings-1.0.55.ebuild
new file mode 100644
index 000000000000..a85095ee47b2
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.55.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jruby/jcodings/archive/refs/tags/jcodings-1.0.55.tar.gz --slot 1 --keywords "~amd64 ~x86" --ebuild jcodings-1.0.55.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.jruby.jcodings:jcodings:1.0.55"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Byte based encoding support library for java"
+HOMEPAGE="https://github.com/jruby/jcodings"
+SRC_URI="https://github.com/jruby/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=virtual/jdk-11:*
+"
+
+RDEPEND="
+ >=virtual/jre-11:*
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR="src"
+JAVA_RESOURCE_DIRS="resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="test"