summaryrefslogtreecommitdiff
path: root/dev-java/jcodings/jcodings-1.0.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/jcodings/jcodings-1.0.11-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/jcodings/jcodings-1.0.11-r1.ebuild')
-rw-r--r--dev-java/jcodings/jcodings-1.0.11-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/jcodings/jcodings-1.0.11-r1.ebuild b/dev-java/jcodings/jcodings-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..16aeaf0589a1
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.11-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Byte-based encoding support library for Java"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*
+ test? (
+ dev-java/ant-junit:0
+ >=dev-java/junit-4.8:4
+ )"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}