summaryrefslogtreecommitdiff
path: root/dev-java/jcifs/jcifs-1.3.19-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-java/jcifs/jcifs-1.3.19-r1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-java/jcifs/jcifs-1.3.19-r1.ebuild')
-rw-r--r--dev-java/jcifs/jcifs-1.3.19-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/jcifs/jcifs-1.3.19-r1.ebuild b/dev-java/jcifs/jcifs-1.3.19-r1.ebuild
new file mode 100644
index 000000000000..b8169cb79866
--- /dev/null
+++ b/dev-java/jcifs/jcifs-1.3.19-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
+SRC_URI="https://jcifs.samba.org/src/${P}.tgz"
+HOMEPAGE="https://jcifs.samba.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+CDEPEND="java-virtuals/servlet-api:3.0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+JAVA_GENTOO_CLASSPATH="servlet-api-3.0"
+
+JAVA_SRC_DIR="src"
+
+DOCS=( README.txt )
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples examples
+ einstalldocs
+}