summaryrefslogtreecommitdiff
path: root/dev-java/jbcrypt/jbcrypt-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 16:18:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 16:18:45 +0100
commit2ffbfc63824a9e437090fb3c744670dd45369ae0 (patch)
treead31a5650e31f93490157943681bb982f8a4520c /dev-java/jbcrypt/jbcrypt-0.4.ebuild
parent399fa07bfac673a8846466b16c76549e329b55b8 (diff)
gentoo auto-resync : 20:05:2023 - 16:18:45
Diffstat (limited to 'dev-java/jbcrypt/jbcrypt-0.4.ebuild')
-rw-r--r--dev-java/jbcrypt/jbcrypt-0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/jbcrypt/jbcrypt-0.4.ebuild b/dev-java/jbcrypt/jbcrypt-0.4.ebuild
new file mode 100644
index 000000000000..49671984ecdb
--- /dev/null
+++ b/dev-java/jbcrypt/jbcrypt-0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.mindrot:jbcrypt:0.4"
+JAVA_TESTING_FRAMEWORKS="junit"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java implementation of OpenBSD's Blowfish password hashing code"
+HOMEPAGE="https://www.mindrot.org/projects/jBCrypt"
+SRC_URI="https://www.mindrot.org/files/jBCrypt/jBCrypt-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/jBCrypt-${PV}"
+
+JAVA_SRC_DIR="src"
+JAVA_TEST_SRC_DIR="test"
+JAVA_TEST_GENTOO_CLASSPATH="junit"