summaryrefslogtreecommitdiff
path: root/dev-java/javacup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-java/javacup
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-java/javacup')
-rw-r--r--dev-java/javacup/Manifest1
-rw-r--r--dev-java/javacup/javacup-0.11b_p20151001-r1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-java/javacup/Manifest b/dev-java/javacup/Manifest
index 0a370ffe62dc..106b599043d0 100644
--- a/dev-java/javacup/Manifest
+++ b/dev-java/javacup/Manifest
@@ -1,4 +1,5 @@
AUX javacup-0.11b_beta20150326-build-xml-svn.patch 1385 BLAKE2B 43ed5b0c75aa308f2301d8e7d633ca69689a1772a7d8f0f7dbd6f914f1bbf571dcef0ac9fb9cacbe07aaa8c50fca69f0fa95f661314dfab2c16ac96ad50f11f7 SHA512 211157370c61995a05ce45e70941d99da9031174fae2b6e4bbacfdd0c402c451009eb5952a8c3cf8a586402aa138e70733dfd46ce9cf6b5fb680edf65657506c
DIST java-cup-src-11b-20151001.tar.gz 313405 BLAKE2B 126944916d120dd2150e4a665fea6d216f3d55e002a72b581621df726e4bf0e0664f9ff925189c97162582277c08a4f121e056299ea5a3f5c10cc31d7c0feb9c SHA512 70bb6a0e13fe52694980040205fcf5b3e904c4a07e50c7740c55cc3bb481496c5c071377757b94f59807b936b8c4fdde5423d78cc2d12a7ada1870f71cd9f47e
+EBUILD javacup-0.11b_p20151001-r1.ebuild 2790 BLAKE2B 7539940729bc92676ef614ec76a0287da8f38a8bc3a25616496f8c4b25e178a86dfbcd892ef08dfb96b170e2e3114412eac40fe1862dbe1b39ae7fa5abd56889 SHA512 ae3f59c9d126dfa5db224313cc631df3055b48af66457c9b03340caa4e28afbfe83a5d272d9a8e94b06b93aa472ea5c414a5a84ee6a49795674753e7ef160279
EBUILD javacup-0.11b_p20151001.ebuild 2798 BLAKE2B 8bf3e57971595295db4c5af67e9d810577fb1cd017a226ad4bf6f1835fa96d1150f9135e7ac5e4b2b374d2d433f58d6ad55193465a8f092e8d82c83c949f2050 SHA512 cc8885b9d6dfa24f39d9ad9ad28f4af755d1c50182b388f7ce1243125de58aade47872647b2fd5add3a4f80af1b88697da39855fab8d0d95e49e6db75b087bfb
MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/javacup/javacup-0.11b_p20151001-r1.ebuild b/dev-java/javacup/javacup-0.11b_p20151001-r1.ebuild
new file mode 100644
index 000000000000..587cf479708e
--- /dev/null
+++ b/dev-java/javacup/javacup-0.11b_p20151001-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PV=${PV/_beta/-}
+MY_PV=${MY_PV/_p/-}
+MY_PV=${MY_PV#0.}
+MY_P=java-cup-${MY_PV%-*}
+
+DESCRIPTION="CUP Parser Generator for Java"
+HOMEPAGE="http://www2.cs.tum.edu/projects/cup/"
+SRC_URI="http://www2.cs.tum.edu/projects/cup/releases/java-cup-src-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="dev-java/ant-core:0
+ dev-java/jflex:0
+ >=virtual/jdk-1.8:*"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+JAVA_ANT_CLASSPATH_TAGS+=" taskdef"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+ # Bizarrely, you can't build from the tarball without this patch.
+ eapply "${FILESDIR}"/${PN}-0.11b_beta20150326-build-xml-svn.patch
+
+ # The JFlex package name has changed to lower case.
+ sed -i "s/JFlex\./jflex./g" build.xml || die
+
+ # Remove the bundled JFlex.
+ rm -v bin/JFlex.jar || die
+}
+
+src_configure() {
+ EANT_GENTOO_CLASSPATH_EXTRA=$(java-pkg_getjars --build-only ant-core,jflex)
+ java-ant-2_src_configure
+}
+
+src_compile() {
+ # Annoyingly javacup bundles an older version of itself that will
+ # break jflex if that has already been built against this newer
+ # version beforehand. Even more annoyingly, the binary download is
+ # built with Java 8, which isn't much use to us. We therefore use
+ # any installed javacup that is newer than the bundled version where
+ # possible. If this approach turns out to be unworkable then we may
+ # just have to use the bundled jflex for bootstrapping.
+ if has_version \>=${CATEGORY}/${PN}-0.11b:${SLOT}; then
+ # Use PORTAGE_QUIET to suppress a QA warning that is spurious
+ # thanks to has_version above. This is Portage-specific but
+ # showing the warning elsewhere isn't the end of the world.
+ einfo "Bootstrapping with installed javacup ..."
+ EANT_GENTOO_CLASSPATH_EXTRA+=":$(PORTAGE_QUIET=1 java-pkg_getjars --build-only javacup)" eant
+ else
+ einfo "Bootstrapping with bundled javacup ..."
+ EANT_GENTOO_CLASSPATH_EXTRA+=":${S}/bin/${MY_P:0:-1}.jar" eant
+ fi
+
+ # Clean everything except the new jar.
+ rm -rv java/ classes/ || die
+
+ einfo "Recompiling with newly built javacup ..."
+ EANT_GENTOO_CLASSPATH_EXTRA+=":${S}/dist/${MY_P}.jar" eant
+
+ use doc && ejavadoc -sourcepath src/ -d javadoc java_cup
+}
+
+src_install() {
+ java-pkg_newjar dist/${MY_P}.jar
+ java-pkg_newjar dist/${MY_P}-runtime.jar ${PN}-runtime.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ java-pkg_register-ant-task
+
+ dodoc changelog.txt
+ docinto html
+ dodoc manual.html
+
+ use source && java-pkg_dosrc java/*
+ use doc && java-pkg_dojavadoc javadoc
+}