summaryrefslogtreecommitdiff
path: root/dev-java/jansi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-java/jansi
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-java/jansi')
-rw-r--r--dev-java/jansi/Manifest2
-rw-r--r--dev-java/jansi/jansi-2.4.0-r1.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-java/jansi/Manifest b/dev-java/jansi/Manifest
index c36cf149c3b4..734052c8fc0c 100644
--- a/dev-java/jansi/Manifest
+++ b/dev-java/jansi/Manifest
@@ -1,3 +1,5 @@
DIST jansi-1.13.tar.gz 253219 BLAKE2B 89fc81710bc0860c717241c97fe2e7a148ccbaa5fb1e7db30b978aa69cddccbc9ea45a0e30ef384c42a741d707f5eab73ce8b2a76e1095c66a2c95f9088f28f0 SHA512 9c4bb0b7435c102068718e039900828994f1ba60ed44307eb726eb91a2884bc406688c2747635b9353f3bd68a6bf0e7c082a4069343b59efffc900f59c563fde
+DIST jansi-2.4.0.tar.gz 225579 BLAKE2B f07dfde9b789d62ec31999632e35609143289c5ab0972ce7cb931dea72ba41e6f2b9b74f7b3d82050e9ed4abd89386040d5268c408d787d3edd49fcdf0cce965 SHA512 4172b264463b847d6008dfad5c80246b029c7add2fd659f4b1c636891a86860f8f5ddd0ce0a5150065faeae72b19682339dda2d019c82f45d8f1be7a547e4558
EBUILD jansi-1.13.ebuild 946 BLAKE2B 93adfeeca34d5c12afb71ee93d27f86068d550d45c4017dc80a1b5c47d868edf3d1eae1794d30c7dd6d5f962e496410a37da33183a74d96baac8604a2ee875eb SHA512 085e83dfc7e435bf2824fb196a4cf4fc276befebab7e89a0a6c63281323da860202e4278fc5e797759452d6a7a827820c7325e63436505d6e5f92f30dfd432d8
+EBUILD jansi-2.4.0-r1.ebuild 2347 BLAKE2B 0e50d0695d1dd5810654fa2aa9d2d96630d9e551a9e3cef788d2dca79213775fa73dcac612da58af21e799ad373731a126d61288096a352fac53b403d46f8da4 SHA512 ff09eb4c4a019443991f41176b6bb22a346f6f02edb6a4d18ae067d9c39acc586d1be560c35fad4029cca9c43ecaeec450afbfd14f722ddff68c5fe2407b82ba
MISC metadata.xml 492 BLAKE2B 6620d0d7d7c5cc16b029617d431785e423a84ce8d23e06cc7a7a88c876d62223113be6c867d46b3a8537e3376174d00e2e3db19b3a178354140066a37da9956a SHA512 a460cd0627fa5d6ea41178f6268454f3841e67bbabaa7426d9d0e96caf941881694acd88e6c9a038ad5eafd46c78f7b0a29a3308e13be676f26d73e9fd9af79c
diff --git a/dev-java/jansi/jansi-2.4.0-r1.ebuild b/dev-java/jansi/jansi-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..75e764ffdbfd
--- /dev/null
+++ b/dev-java/jansi/jansi-2.4.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/fusesource/jansi/archive/refs/tags/jansi-2.4.0.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jansi-2.4.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.fusesource.jansi:jansi:2.4.0"
+
+inherit java-pkg-2 java-pkg-simple toolchain-funcs
+
+DESCRIPTION="Jansi is a java library for generating and interpreting ANSI escape sequences."
+HOMEPAGE="http://fusesource.github.io/jansi"
+SRC_URI="https://github.com/fusesource/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Compile dependencies
+# POM: pom.xml
+# test? info.picocli:picocli-codegen:4.5.2 -> !!!artifactId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.7.0 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter-params:5.7.0 -> !!!groupId-not-found!!!
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+# junit-jupiter is not available in ::gentoo
+# test? (
+# !!!artifactId-not-found!!!
+# !!!groupId-not-found!!!
+# )
+#"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {changelog,readme}.md license.txt )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+JAVA_MAIN_CLASS="org.fusesource.jansi.AnsiMain"
+
+# junit-jupiter is not available in ::gentoo
+#JAVA_TEST_GENTOO_CLASSPATH="!!!artifactId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!"
+#JAVA_TEST_SRC_DIR="src/test/java"
+#JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+src_prepare() {
+ default
+ # Remove this directory containing libjansi.so, libjansi.jnilib and jansi.dll
+ rm -r "${JAVA_RESOURCE_DIRS}/org/fusesource/jansi/internal/native" || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+
+ # build native library.
+ local args=(
+ CCFLAGS="${CFLAGS} ${CXXFLAGS} -Os -fPIC -fvisibility=hidden"
+ LINKFLAGS="-shared ${LDFLAGS}"
+ CC="$(tc-getCC)"
+ STRIP="$(tc-getSTRIP)"
+ LIBNAME="libjansi-$(ver_cut 1-2).so"
+ )
+ emake "${args[@]}" native
+}
+
+src_install() {
+ # default # https://bugs.gentoo.org/789582
+ # deafult fails with
+ # make: *** No rule to make target 'install'. Stop.
+ java-pkg_doso target/native--/libjansi-$(ver_cut 1-2).so
+ java-pkg-simple_src_install
+}