summaryrefslogtreecommitdiff
path: root/dev-java/jansi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jansi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jansi')
-rw-r--r--dev-java/jansi/Manifest6
-rw-r--r--dev-java/jansi/files/jansi-1.11-build.xml298
-rw-r--r--dev-java/jansi/jansi-1.11-r1.ebuild53
-rw-r--r--dev-java/jansi/jansi-1.5-r2.ebuild36
-rw-r--r--dev-java/jansi/metadata.xml14
5 files changed, 407 insertions, 0 deletions
diff --git a/dev-java/jansi/Manifest b/dev-java/jansi/Manifest
new file mode 100644
index 000000000000..b232999b34b1
--- /dev/null
+++ b/dev-java/jansi/Manifest
@@ -0,0 +1,6 @@
+AUX jansi-1.11-build.xml 14529 BLAKE2B ea9358a4a64e077ba9173f6f0d0548647489980cff2626760b6c92df9774117bc6ff32f4647c8b89b21b4e37722f018e4f1fd0ca2cfa5915a83e253f9c18d250 SHA512 cc60a9f48f220ee13a22ed814409126524d22f2329c574e61974e26fd70b9a53f703ade06bb6921c13f370016be79c00d111368018132abee20780e99096c0a5
+DIST jansi-1.11.tar.gz 252095 BLAKE2B 72b22392fa6731f49ebb5c2e94cdf7918ca37d5c73ccb14d8810402c9ec120b1220a739e54516eeb5355ad4dd74d01ae398a6003679c60b1dd6f1648691b2efa SHA512 4a19d52055da3ce08b6d797fb8e8241af86f1b9b30e12f4de24655edbd72d256b310d58fc6e106cae1384f9b0ab99cd7f2128d53296875fba5422bfc0e8410f1
+DIST jansi-1.5.zip 211616 BLAKE2B 754105218e62d095f9f070ba7f66b68dd2cfbf1b7d8f95ea6dc40f01e536fd8997e2bfca481a4c57cafabc6fe044de5de171b51429e07081ebe1824a5cd5d3d0 SHA512 784c01b7ab48307cf881439d5c3531949a6459e8a90667f1ee7a73f9cbce72710fcf4af8b4cae610d15085641567c0d51cab487488daa0c1b0a4605864de2775
+EBUILD jansi-1.11-r1.ebuild 1127 BLAKE2B 36c514f4e6797c2ac98e7d98ac7ad671f87613afad98083dcdbc0dcea883e14b47d0d7a3170f5177d783eea89849d2167f70695e06396654a6f84c870d7aa93a SHA512 127446458448ddb88333e4425b28475e6e9dd31f1dd7e90bd6e6b7aeec9040deafd96fae931064e922fc478f9d0cde33649da99787287c74b6de464863908434
+EBUILD jansi-1.5-r2.ebuild 674 BLAKE2B bd3b686e6c35721f33d73357434a37800519b0b370edeb97288be68a98e95b04045c397700fbf78e0d3aa4dad82da714e20dcc30f0bcde1fdd9f666fbd302b19 SHA512 07dd8bc9d822b963be6db3ca5e39bc160ace104741ef0786de3a8482eeb7f075c67fbc60d4f6e5cc46c4ef58f4263960f796c1c0373c07baa0149f09cace0910
+MISC metadata.xml 491 BLAKE2B 57979797604525188358a5e2bbf92bd7cc40e9513710d9907302df960f0fb0961b3c8eca15bc09b53cae259dbe3b512d149a4e9fb2bb5e3b1ad6a13700af3c4b SHA512 46a12388363e4b59001bf8cf67923a4f38d8a4409fe158a813c9403e0da6067a8aff418cda7e0d02dc905e38591ded15e46b8f8095acb62d0a83a65146550669
diff --git a/dev-java/jansi/files/jansi-1.11-build.xml b/dev-java/jansi/files/jansi-1.11-build.xml
new file mode 100644
index 000000000000..058559ce0847
--- /dev/null
+++ b/dev-java/jansi/files/jansi-1.11-build.xml
@@ -0,0 +1,298 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/4/13 7:11 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jansi-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jansi-1.11"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.7/junit-4.7.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/Test*.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/Test*.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"
+ dest="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.7"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.7/junit-4.7.jar"
+ dest="${maven.repo.local}/junit/junit/4.7/junit-4.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jansi/jansi-1.11-r1.ebuild b/dev-java/jansi/jansi-1.11-r1.ebuild
new file mode 100644
index 000000000000..521a8813c78f
--- /dev/null
+++ b/dev-java/jansi/jansi-1.11-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# TODO: Get doc (missing classpath entries) working.
+JAVA_PKG_IUSE="source test"
+
+inherit vcs-snapshot java-pkg-2 java-ant-2
+
+DESCRIPTION="A library that allows you to use ANSI escape sequences in your console output"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/tarball/${PN}-project-${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.11"
+KEYWORDS="amd64 x86"
+
+CDEPEND="dev-java/jansi-native:0"
+
+DEPEND="${CDEPEND}
+ test? (
+ dev-java/ant-junit4:0
+ dev-java/junit:4
+ )
+ >=virtual/jdk-1.7"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}/jansi"
+
+EANT_GENTOO_CLASSPATH="jansi-native"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+EANT_TEST_GENTOO_CLASSPATH="ant-junit4,junit-4"
+
+src_test() {
+ EANT_EXTRA_ARGS="-Djunit.present=true"
+
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/jansi/jansi-1.5-r2.ebuild b/dev-java/jansi/jansi-1.5-r2.ebuild
new file mode 100644
index 000000000000..42ff134dafcb
--- /dev/null
+++ b/dev-java/jansi/jansi-1.5-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library to output ANSI escape sequences in console"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/archive/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc64 x86"
+
+CDEPEND="dev-java/jansi-native:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_GENTOO_CLASSPATH="jansi-native"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ default
+ rm -rv src/test || die
+}
diff --git a/dev-java/jansi/metadata.xml b/dev-java/jansi/metadata.xml
new file mode 100644
index 000000000000..c609e5e96c84
--- /dev/null
+++ b/dev-java/jansi/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>
+ Jansi is a small java library that allows you to use ANSI escape sequences to format your console output which works even on windows.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fusesource/jansi</remote-id>
+ </upstream>
+</pkgmetadata>