summaryrefslogtreecommitdiff
path: root/dev-java/jakarta-regexp/jakarta-regexp-1.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-java/jakarta-regexp/jakarta-regexp-1.4-r3.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-java/jakarta-regexp/jakarta-regexp-1.4-r3.ebuild')
-rw-r--r--dev-java/jakarta-regexp/jakarta-regexp-1.4-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jakarta-regexp/jakarta-regexp-1.4-r3.ebuild b/dev-java/jakarta-regexp/jakarta-regexp-1.4-r3.ebuild
new file mode 100644
index 000000000000..6fcce04eebce
--- /dev/null
+++ b/dev-java/jakarta-regexp/jakarta-regexp-1.4-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="100% Pure Java Regular Expression package"
+SRC_URI="mirror://apache/jakarta/regexp/source/${P}.tar.gz"
+HOMEPAGE="https://jakarta.apache.org/"
+
+SLOT="${PV}"
+IUSE=""
+LICENSE="Apache-1.1"
+KEYWORDS="amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="
+ >=virtual/jre-1.8:*"
+
+DEPEND="
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/java"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}