summaryrefslogtreecommitdiff
path: root/dev-java/j2ssh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/j2ssh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/j2ssh')
-rw-r--r--dev-java/j2ssh/Manifest5
-rw-r--r--dev-java/j2ssh/files/0.2.9-extras.patch201
-rw-r--r--dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch40
-rw-r--r--dev-java/j2ssh/j2ssh-0.2.9.ebuild44
-rw-r--r--dev-java/j2ssh/metadata.xml15
5 files changed, 305 insertions, 0 deletions
diff --git a/dev-java/j2ssh/Manifest b/dev-java/j2ssh/Manifest
new file mode 100644
index 000000000000..e07b3fa6a034
--- /dev/null
+++ b/dev-java/j2ssh/Manifest
@@ -0,0 +1,5 @@
+AUX 0.2.9-extras.patch 7597 BLAKE2B a3ff2d110ac76e91a7cc3f5287fd80fcd26ea4f073a42c5c430a961afc4ef36beb53a29303b8646cc19370dd318d67065f901fac78818f9b432e326aea51a502 SHA512 e60f449e7cd39c1cc551a012c97f5b1cca229d6a08c06abfea6c47a0e2577d36887ce5e710dae2a1db5d1436b1eb0a13c5bdcef84555c678d3b54124fe6ce17d
+AUX 0.2.9-no-versioned-jars.patch 2187 BLAKE2B 42409b824c8fae59ecf42a531618432f1fa9ca873388b44e7cbbb94e3ad46dedd460b029e802a39a85f3da0d380e16965089e51e544b97495f72b6679f9c62e2 SHA512 5ef6e3f1f51a241f0a45810a561f4a77ddb2fe706e7ae4d0f6e36c28416435eed50cdec33debf7434f788c28f5b147987df3b1a12e59f8a0fade31183f57332f
+DIST j2ssh-0.2.9-src.tar.gz 2182523 BLAKE2B 1c5424ac99a466d3ac114160c133d8d6daed430f67bce35300290e14bc7540c73d5698f728f2cd43f7050877c2f89978c118a420375ffb5bc6c207c397e5afd2 SHA512 d7720766dcf50205089fa22d026721dc25de5def1d451fcb6680832017becc3fc8d76c2ffb5ed2e2190e08c864da24d2544515478956f78ac4d8cf4126cab6e8
+EBUILD j2ssh-0.2.9.ebuild 1015 BLAKE2B d2d738c77687d999e8b42dc5b20e41dc5fa4f341eff4f7ef59ba53ddfd6b69551ab272fe0d748407ac2f0dfcec7703114cbecf2e258dc8ede965b66ec2b416ef SHA512 0fc3e1efd4406c9d54d481dad30a7fa7b852452955059ee2b4e570fcc6fb1d93b0a734613e968825b36f43929ee749fe1493cc0e3be5c0e22e94bc51a77c7547
+MISC metadata.xml 494 BLAKE2B a9ae8d475130ee65e10ad589ab2a28f974463f20822b7d2bd082cea309f658609375ac0b597801c636d9f27917e94f08c9c65e3b48dda4b5ba3ad803df11ef8f SHA512 dc20b956e35a2a5098710ed97d00cd15979a6da488b4618cd262803f093e9281fdeb00f5a828cc0026c7b809c186d10f77683498b2380ed8c46d519696308b18
diff --git a/dev-java/j2ssh/files/0.2.9-extras.patch b/dev-java/j2ssh/files/0.2.9-extras.patch
new file mode 100644
index 000000000000..d958cba19b97
--- /dev/null
+++ b/dev-java/j2ssh/files/0.2.9-extras.patch
@@ -0,0 +1,201 @@
+diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayReader.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayReader.java
+--- j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayReader.java 2007-04-28 21:02:54.000000000 +0200
++++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayReader.java 2008-01-18 19:27:38.000000000 +0100
+@@ -118,7 +118,13 @@
+ byte[] chars = new byte[(int) len];
+ System.arraycopy(data, start + 4, chars, 0, len);
+
+- return new String(chars);
++ try {
++ return new String(chars, "UTF-8");
++ }
++ catch(java.io.UnsupportedEncodingException e) {
++ // This should never happen, UTF-8 is necessarily supported.
++ return new String(chars);
++ }
+ }
+
+ /**
+@@ -163,6 +169,12 @@
+ byte[] raw = new byte[(int) len];
+ read(raw);
+
+- return new String(raw);
++ try {
++ return new String(raw, "UTF-8");
++ }
++ catch(java.io.UnsupportedEncodingException e) {
++ // This should never happen, UTF-8 is necessarily supported.
++ return new String(raw);
++ }
+ }
+ }
+diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayWriter.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayWriter.java
+--- j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayWriter.java 2007-04-29 10:54:48.000000000 +0200
++++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayWriter.java 2008-01-18 19:30:36.000000000 +0100
+@@ -190,15 +190,15 @@
+ if (str == null) {
+ writeInt(0);
+ } else {
+- /*
+- writeInt(str.length());
+- // don't use US-ASCII by default!
+- write(str.getBytes());
+- */
+- // patch as of version 0.2.9
+- // for UTF-8 length of string is not necessarily
+- // equal to number of bytes
+- byte[] strBytes = str.getBytes();
++ byte[] strBytes;
++ try {
++ strBytes = str.getBytes("UTF-8");
++ }
++ catch(java.io.UnsupportedEncodingException e) {
++ // This should never happen, UTF-8 is necessarily supported.
++ strBytes = str.getBytes();
++ }
++
+ writeInt(strBytes.length);
+ write(strBytes);
+ }
+diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java
+--- j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java 2007-04-28 21:02:54.000000000 +0200
++++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java 2008-01-18 19:26:58.000000000 +0100
+@@ -38,7 +38,7 @@
+ */
+ public class SftpFileInputStream extends InputStream {
+ SftpFile file;
+- UnsignedInteger64 position = new UnsignedInteger64("0");
++ UnsignedInteger64 position;
+
+ /**
+ * Creates a new SftpFileInputStream object.
+@@ -48,16 +48,47 @@
+ * @throws IOException
+ */
+ public SftpFileInputStream(SftpFile file) throws IOException {
++ this(file, 0);
++ }
++
++ /**
++ * Creates a new SftpFileInputStream object and sets the file offset to the specified position.
++ *
++ * @param file
++ * @param position the initial file offset, must be >=0
++ *
++ * @throws IOException
++ */
++ public SftpFileInputStream(SftpFile file, long position) throws IOException {
+ if (file.getHandle() == null) {
+ throw new IOException("The file does not have a valid handle!");
+ }
+-
++
+ if (file.getSFTPSubsystem() == null) {
+- throw new IOException(
+- "The file is not attached to an SFTP subsystem!");
++ throw new IOException("The file is not attached to an SFTP subsystem!");
+ }
+-
++
+ this.file = file;
++ this.position = new UnsignedInteger64(""+position);
++ }
++
++ /**
++ * Returns the current offset within the file.
++ *
++ * @return the current offset within the file
++ */
++ public long getPosition() {
++ return position.longValue();
++ }
++
++ /**
++ * Sets the current file offset to the given position.
++ * Subsequent calls to read methods will start reading data at this position.
++ *
++ * @param position the new offset, must be >=0
++ */
++ public void setPosition(long position) {
++ this.position = new UnsignedInteger64(""+position);
+ }
+
+ /**
+diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java
+--- j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java 2007-04-28 21:02:54.000000000 +0200
++++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java 2008-01-18 19:08:55.000000000 +0100
+@@ -38,7 +38,7 @@
+ */
+ public class SftpFileOutputStream extends OutputStream {
+ SftpFile file;
+- UnsignedInteger64 position = new UnsignedInteger64("0");
++ UnsignedInteger64 position;
+
+ /**
+ * Creates a new SftpFileOutputStream object.
+@@ -48,6 +48,18 @@
+ * @throws IOException
+ */
+ public SftpFileOutputStream(SftpFile file) throws IOException {
++ this(file, 0);
++ }
++
++ /**
++ * Creates a new SftpFileOutputStream object and sets the file offset to the specified position.
++ *
++ * @param file
++ * @param position the initial file offset, must be >=0
++ *
++ * @throws IOException
++ */
++ public SftpFileOutputStream(SftpFile file, long position) throws IOException {
+ if (file.getHandle() == null) {
+ throw new IOException("The file does not have a valid handle!");
+ }
+@@ -58,6 +70,7 @@
+ }
+
+ this.file = file;
++ this.position = new UnsignedInteger64(""+position);
+ }
+
+ /**
+diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java
+--- j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java 2007-04-28 21:02:54.000000000 +0200
++++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java 2008-01-21 17:48:06.000000000 +0100
+@@ -231,16 +231,28 @@
+ }
+
+ /**
++ * Creates the directory with the specified path. The default permissions for the directory are 0755 ("rwxr-xr-x").
+ *
++ * @param path the path to the directory to create
++ * @throws IOException if an error occurs
++ */
++ public synchronized void makeDirectory(String path) throws IOException {
++ makeDirectory(path, 0755); // default to 755 octal (493 decimal): "rwxr-xr-x"
++ }
++
++ /**
++ * Creates the directory with the specified path and file permissions.
+ *
+- * @param path
+- *
+- * @throws IOException
++ * @param path the path to the directory to create
++ * @param permissions the file permissions of the new directory
++ * @throws IOException if an error occurs
+ */
+- public synchronized void makeDirectory(String path)
+- throws IOException {
++ public synchronized void makeDirectory(String path, int permissions) throws IOException {
+ UnsignedInteger32 requestId = nextRequestId();
+- SshFxpMkdir msg = new SshFxpMkdir(requestId, path, new FileAttributes());
++ FileAttributes attrs = new FileAttributes();
++ attrs.setPermissions(new UnsignedInteger32(permissions));
++
++ SshFxpMkdir msg = new SshFxpMkdir(requestId, path, attrs);
+ sendMessage(msg);
+ getOKRequestStatus(requestId);
+ }
diff --git a/dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch b/dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch
new file mode 100644
index 000000000000..26d7672a3414
--- /dev/null
+++ b/dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch
@@ -0,0 +1,40 @@
+diff --git a/j2ssh/build.xml b/j2ssh/build.xml
+index 2c867ee..7ba5814 100644
+--- a/j2ssh/build.xml
++++ b/j2ssh/build.xml
+@@ -52,7 +52,7 @@
+ <mkdir dir="${build.dist.lib}"/>
+
+ <!-- Build the J2SSH library files -->
+- <jar jarfile="${build.dist.lib}/j2ssh-core-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
++ <jar jarfile="${build.dist.lib}/j2ssh-core.jar" basedir="${build.dist.classes}">
+ <include name="com/sshtools/j2ssh/**/*.class"/>
+ <manifest>
+ <attribute name="Product-Version"
+@@ -60,7 +60,7 @@
+ </manifest>
+ </jar>
+
+- <jar jarfile="${build.dist.lib}/j2ssh-ant-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
++ <jar jarfile="${build.dist.lib}/j2ssh-ant.jar" basedir="${build.dist.classes}">
+ <include name="com/sshtools/ant/**/*.class"/>
+ <manifest>
+ <attribute name="Product-Version"
+@@ -68,7 +68,7 @@
+ </manifest>
+ </jar>
+
+- <jar jarfile="${build.dist.lib}/j2ssh-dameon-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
++ <jar jarfile="${build.dist.lib}/j2ssh-dameon.jar" basedir="${build.dist.classes}">
+ <include name="com/sshtools/daemon/**/*.class"/>
+ <exclude name="com/sshtools/daemon/windows/**/*.*"/>
+ <exclude name="com/sshtools/daemon/linux/**/*.*"/>
+@@ -78,7 +78,7 @@
+ </manifest>
+ </jar>
+
+- <jar jarfile="${build.dist.lib}/j2ssh-common-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
++ <jar jarfile="${build.dist.lib}/j2ssh-common.jar" basedir="${build.dist.classes}">
+ <include name="com/sshtools/common/**/*.class"/>
+ <include name="com/sshtools/common/**/*.png"/>
+ <include name="com/sshtools/common/**/*.gif"/>
diff --git a/dev-java/j2ssh/j2ssh-0.2.9.ebuild b/dev-java/j2ssh/j2ssh-0.2.9.ebuild
new file mode 100644
index 000000000000..7d4dd4ea6d5a
--- /dev/null
+++ b/dev-java/j2ssh/j2ssh-0.2.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source doc examples"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java implementation of the SSH protocol"
+HOMEPAGE="https://sourceforge.net/projects/sshtools/ http://www.sshtools.com/"
+SRC_URI="mirror://sourceforge/sshtools/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-java/commons-logging:0
+ dev-java/ant-core:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="commons-logging,ant-core"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-no-versioned-jars.patch"
+ epatch "${FILESDIR}/${PV}-extras.patch"
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/dist/lib/*.jar
+
+ use doc && java-pkg_dojavadoc docs/
+ use source && java-pkg_dosrc "${S}"/src/com
+ use examples && java-pkg_doexamples "${S}"/examples/
+}
diff --git a/dev-java/j2ssh/metadata.xml b/dev-java/j2ssh/metadata.xml
new file mode 100644
index 000000000000..6b55c013d0a1
--- /dev/null
+++ b/dev-java/j2ssh/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>
+ SSHTools is a suite of Java SSH applications providing a Java SSH API,
+ SSH Terminal, SSH secured VNC client, SFTP client and SSH Daemon.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">sshtools</remote-id>
+ </upstream>
+</pkgmetadata>