summaryrefslogtreecommitdiff
path: root/dev-java/hessian/hessian-4.0.37.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/hessian/hessian-4.0.37.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/hessian/hessian-4.0.37.ebuild')
-rw-r--r--dev-java/hessian/hessian-4.0.37.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/hessian/hessian-4.0.37.ebuild b/dev-java/hessian/hessian-4.0.37.ebuild
new file mode 100644
index 000000000000..9b56e9f6f31f
--- /dev/null
+++ b/dev-java/hessian/hessian-4.0.37.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Binary web service protocol"
+HOMEPAGE="http://hessian.caucho.com/"
+SRC_URI="http://hessian.caucho.com/download/${P}-src.jar"
+
+LICENSE="Apache-1.1"
+SLOT="4.0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="doc source"
+
+CDEPEND="java-virtuals/servlet-api:3.0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+JAVA_SRC_DIR="com"
+JAVA_GENTOO_CLASSPATH="servlet-api-3.0"