summaryrefslogtreecommitdiff
path: root/dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild')
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild
new file mode 100644
index 000000000000..7c07b1bd7a7e
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.15-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="hawtjni-project-${PV}"
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/hawtjni-${MY_P}/${PN}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../../{changelog,notice,readme}.md
+}