summaryrefslogtreecommitdiff
path: root/dev-java/gwt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-java/gwt
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-java/gwt')
-rw-r--r--dev-java/gwt/Manifest5
-rw-r--r--dev-java/gwt/files/gwt-2.8.2-build-system.patch13
-rw-r--r--dev-java/gwt/gwt-2.8.2.ebuild77
-rw-r--r--dev-java/gwt/metadata.xml21
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-java/gwt/Manifest b/dev-java/gwt/Manifest
new file mode 100644
index 000000000000..2563bf23f91e
--- /dev/null
+++ b/dev-java/gwt/Manifest
@@ -0,0 +1,5 @@
+AUX gwt-2.8.2-build-system.patch 758 BLAKE2B b1aca717473f2ebee42bfc2902c8eb0012698c8f7a059f5c9d29944b154c1a85ae296d8639271aaa6f749e5fa84de8e4e8ad5da45c90495e1f5ab429eff13740 SHA512 c469c23ded60e5f844abda0001f4ca99fd6756f9bd433f3e8a433c9441db3dd62d0523ab90b3f2eb1bf2b26675ef0f01a3ddf7dd371df844037a9f249c5b59a5
+DIST gwt-2.8.2.zip 22017212 BLAKE2B b112df08885e607c975f9585d6b83e2a12894e974850ada052918e4b946b11bfc8d9cf9d71f4e684121d9d16714885be549eed44d77a119e695c2b50cd6bc6c3 SHA512 ac16311c3b00b36d421eef914e73ad8dea01f022c87fc7ed722fdfee8eed391f1987cc1c34522978afc542cdb90eee791efcdcc725d9a395ab468e458b708074
+DIST gwt-tools-f42d2729a3a8e6ba9b9aec069957bce5dc0f6f6d.zip 577453206 BLAKE2B 83a3824d6418727876b4708ed44ab1f58513a5b39d4e48f9bf21290ca358f76ec2ccd98ce2aee76afe7f621fb1f703bf459b8c3d6a3d4f32d4be807bc723513e SHA512 f4f033c972d955da40258020a9fb84ae90f30b7afeb1ae8044cf00f4f5f45200129bf84e2f69660a4eb80bb60f3a5a1d3c5af69fe9e07e0b985de0e708ca933f
+EBUILD gwt-2.8.2.ebuild 1855 BLAKE2B 3aaa9cc77f59b1de68576ffb181b79cea5df324bca29149430dfca81c114fe07401136e5afb8ee78dddaa7242c0ca00da4263483b7aabd756ff6c87daffb61b5 SHA512 806919aefcd54194e9c1b53066f2c7bd7585151c54b0a7706211dec59bf31e4ec4992a8a26df6217a9265019705c1ef777d1728314344e2dfa08bd42050491ee
+MISC metadata.xml 766 BLAKE2B e023f4897d31fa31c961563600b21d9a03a26b1ac70b75859c66e558177e7b42b747cfb40d22760eb132b44ac5ec2ee8906a48ea09b591e8a5cc1dd7a91cc55e SHA512 c4fdbf613e76d4be2c71a15fc9f99f0cd744aa4508725dc36a11421eee6029a22af833c360b525002a5be76b74494b14ec093945e1c5f25a9c2fb71867cf3f32
diff --git a/dev-java/gwt/files/gwt-2.8.2-build-system.patch b/dev-java/gwt/files/gwt-2.8.2-build-system.patch
new file mode 100644
index 000000000000..82340416e7a7
--- /dev/null
+++ b/dev-java/gwt/files/gwt-2.8.2-build-system.patch
@@ -0,0 +1,13 @@
+--- gwt-2.8.2-orig/common.ant.xml 2017-10-18 22:39:31.000000000 +1100
++++ gwt-2.8.2/common.ant.xml 2020-01-13 13:23:58.653719957 +1100
+@@ -277,9 +277,7 @@
+
+ <macrodef name="gwt.getgitinfo" description="Identifies the GIT info of a workspace">
+ <sequential>
+- <exec executable="git" searchpath="true" outputproperty="gwt.gitrev">
+- <arg line="rev-parse --short HEAD"/>
+- </exec>
++ <property name="gwt.gitrev" value="faff18e7a1f065e3a4ac4ef32ab5cce394557070"/>
+ <!-- Generally, filtering requires a sentinel file so that changes to git rev will
+ be noticed as invalidating the previously-generated filter output. This property
+ names where such a sentinel lives; it is tested with <available/> and created
diff --git a/dev-java/gwt/gwt-2.8.2.ebuild b/dev-java/gwt/gwt-2.8.2.ebuild
new file mode 100644
index 000000000000..0a0f40fa707a
--- /dev/null
+++ b/dev-java/gwt/gwt-2.8.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2 java-utils-2
+
+GWT_TOOLS_COMMIT="f42d2729a3a8e6ba9b9aec069957bce5dc0f6f6d"
+GWT_TOOLS_PN="tools"
+
+GWT_COMMIT="faff18e7a1f065e3a4ac4ef32ab5cce394557070"
+
+DESCRIPTION="Google Web Toolkit library"
+HOMEPAGE="http://www.gwtproject.org/"
+SRC_URI="https://github.com/gwtproject/${PN}/archive/${PV}.zip -> ${P}.zip
+ https://github.com/gwtproject/${GWT_TOOLS_PN}/archive/${GWT_TOOLS_COMMIT}.zip -> ${PN}-${GWT_TOOLS_PN}-${GWT_TOOLS_COMMIT}.zip"
+RESTRICT="mirror"
+SLOT="2.8"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND="
+ dev-java/json:0
+ dev-java/guava:20
+ dev-java/rhino:1.6
+ >=dev-java/asm-5.0.3:4
+ dev-java/eclipse-ecj:4.5
+ dev-java/validation-api:1.0
+"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_BUILD_XML="build.xml"
+EANT_BUILD_TARGET="build"
+EANT_EXTRA_ARGS="-Dgwt.gitrev=${GWT_COMMIT}"
+EANT_GENTOO_CLASSPATH="
+ json
+ asm-4
+ guava-20
+ rhino-1.6
+ eclipse-ecj-4.5
+ validation-api-1.0
+"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-build-system.patch
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ GWT_TOOLS="${WORKDIR}/${GWT_TOOLS_PN}-${GWT_TOOLS_COMMIT}" \
+ GWT_VERSION="${PV}" \
+ java-pkg-2_src_compile
+}
+
+src_test() {
+ GWT_TOOLS="${WORKDIR}/${GWT_TOOLS_PN}-${GWT_TOOLS_COMMIT}" \
+ GWT_VERSION="${PV}" \
+ TZ=America/Los_Angeles ANT_OPTS=-Dfile.encoding=UTF-8 \
+ ant ${EANT_EXTRA_ARGS} test || die
+}
+
+src_install() {
+ java-pkg_dojar \
+ build/lib/*.jar
+ java-pkg_dolauncher i18nCreator --main com.google.gwt.i18n.tools.I18NCreator --jar gwt-dev.jar
+ java-pkg_dolauncher webAppCreator --main com.google.gwt.user.tools.WebAppCreator --jar gwt-dev.jar
+}
diff --git a/dev-java/gwt/metadata.xml b/dev-java/gwt/metadata.xml
new file mode 100644
index 000000000000..15024df0cf40
--- /dev/null
+++ b/dev-java/gwt/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription lang="en">
+ GWT is a development toolkit for building and optimizing
+ complex browser-based applications. Its goal is to enable
+ productive development of high-performance web applications
+ without the developer having to be an expert in browser
+ quirks, XMLHttpRequest, and JavaScript. It’s open source,
+ completely free, and used by thousands of developers around
+ the world.
+ </longdescription>
+</pkgmetadata>