summaryrefslogtreecommitdiff
path: root/dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild')
-rw-r--r--dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild b/dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..b71050b603dd
--- /dev/null
+++ b/dev-java/gnu-jaf/gnu-jaf-1.1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="GNU implementation of the JavaBeans Activation Framework"
+HOMEPAGE="https://www.gnu.org/software/classpathx/jaf/jaf.html"
+SRC_URI="mirror://gnu/classpathx/activation-${PV}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1"
+KEYWORDS="amd64 ppc64 x86"
+
+DEPEND="
+ >=virtual/jdk-1.8"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+S=${WORKDIR}/activation-${PV}
+
+EANT_BUILD_TARGET="activation.jar"
+
+DOCS=( AUTHORS ChangeLog )
+
+src_install() {
+ java-pkg_dojar activation.jar
+ einstalldocs
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc source/*
+}