summaryrefslogtreecommitdiff
path: root/dev-java/fontbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/fontbox
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/fontbox')
-rw-r--r--dev-java/fontbox/Manifest6
-rw-r--r--dev-java/fontbox/files/fontbox-1.7.1-build.xml250
-rw-r--r--dev-java/fontbox/fontbox-1.7.1-r1.ebuild50
-rw-r--r--dev-java/fontbox/fontbox-1.8.11.ebuild50
-rw-r--r--dev-java/fontbox/metadata.xml19
5 files changed, 375 insertions, 0 deletions
diff --git a/dev-java/fontbox/Manifest b/dev-java/fontbox/Manifest
new file mode 100644
index 000000000000..3e07f700f48d
--- /dev/null
+++ b/dev-java/fontbox/Manifest
@@ -0,0 +1,6 @@
+AUX fontbox-1.7.1-build.xml 10618 BLAKE2B 6fe7b6a3b274ee3a419675c56e86a865d1e05c393d39b5bd897bf54cf6c45fb27674078747da927c3df1e9d017d332ccf1aec00499947a62fc850590adfd5c31 SHA512 8f3173325808c096cca21f69bb70f9ed5a43c0e56b5d6487604de399625bb40fbeecc569c068bb6840a87fb5edcc3e22171d8c6fab28a2c00b36172196c1935c
+DIST fontbox-1.7.1.zip 9167805 BLAKE2B f9e02d1540eaf7e4bb748906e56887494d81eecc88685fa9d758cb50712a530528573f4a7e5f816b4ff57d664a416b35444517d840c9b37239ec1e2b5a62b5a1 SHA512 8b2af3d8f431626c106e4f6e9e1d59d14abcd58cfdc9553f20c5057eef9f9cfbd0287e14e58e4d34472ad81198eb3f4d0a2fd6e88bd1fa5cbcf01e4befbf77d0
+DIST pdfbox-1.8.11-src.zip 11026359 BLAKE2B b3eb1add38e9bd0e5a1fcb116263fdbc372d6adb77132aeb0647a6c5d2c2b735345220f0a5c22caa97d04f78ad6517df388327aaa625677bd8c99d2051329a9c SHA512 05c8e5075379ed5ebb09555b39434dd936fce9dd24445871d24ea7f0f6afa49e74242bf0c9eba2d1a847b505143789b687dd039ca51ce76851132f2f18d434d1
+EBUILD fontbox-1.7.1-r1.ebuild 971 BLAKE2B 5d0a36f8cca1a5793386111563cf793a57c665f903c467c8a244dcfbe6986b59072661fbee1b363d1d0aaff1dc1f921d016c0723a3237a722ae9b05227c1fc0b SHA512 44d237b4a9e505dc45ff2bd0afbd4cbe8452ffc66e7b6155dfe3ecc00dedd1467e8a5870d429ad494cd48d8437461dcedeaa5c68f2fb02f613363c5134abc2d5
+EBUILD fontbox-1.8.11.ebuild 1146 BLAKE2B c448e815ad5f90dd1b689948a994e7c37e5d48c2b292c0bb40fffcfc8046591ddb4693f4b6c07abdb8f817f5cb6ec42c4271c2d63e240a6e48810ce44e2811ba SHA512 ee11087e709c98760b273d3d71848b233ed7906d8d1bbc81d55ff5b2418bfa71d6033e98e83dea8823ffcc7034570f3129101ffbacca8ca347d11e2a13026956
+MISC metadata.xml 586 BLAKE2B dced74e0b5e677040e5bc60d35050eb2acd6e0c9f88f02ba5fe41dfcf6d90a1dacd70e17f85d1d091b6e4a6135cf31c54629107ae0fe33ff863644f849ceb96d SHA512 d7f91851ceae4b6d8a9315e201f5e5ba09a92c29ae26f4abc8dd4faeec30b1de64b1528f89e09cb84372197de93576a468a6e5897ca55a62c8c39c53e4943809
diff --git a/dev-java/fontbox/files/fontbox-1.7.1-build.xml b/dev-java/fontbox/files/fontbox-1.7.1-build.xml
new file mode 100644
index 000000000000..ccde1983d680
--- /dev/null
+++ b/dev-java/fontbox/files/fontbox-1.7.1-build.xml
@@ -0,0 +1,250 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 8/2/12 1:39 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="fontbox-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="fontbox-1.7.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.8.1"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/fontbox/fontbox-1.7.1-r1.ebuild b/dev-java/fontbox/fontbox-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..d2cd213f9ef4
--- /dev/null
+++ b/dev-java/fontbox/fontbox-1.7.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="pdfbox"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An open source Java library for parsing font files"
+HOMEPAGE="https://pdfbox.apache.org/"
+SRC_URI="https://archive.apache.org/dist/pdfbox/${PV}/${MY_P}-src.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="1.7"
+KEYWORDS="amd64 ~arm64 ppc64 x86 ~x64-macos"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+
+src_prepare() {
+ default
+ cp -v "${FILESDIR}/${P}-build.xml" build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/fontbox/fontbox-1.8.11.ebuild b/dev-java/fontbox/fontbox-1.8.11.ebuild
new file mode 100644
index 000000000000..182cd4100ed7
--- /dev/null
+++ b/dev-java/fontbox/fontbox-1.8.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN="pdfbox"
+MY_P="${MY_PN}-${PV}"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="An open source Java library for parsing font files"
+HOMEPAGE="https://pdfbox.apache.org/"
+SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_P}-src.zip"
+LICENSE="Apache-2.0"
+SLOT="1.8"
+KEYWORDS="amd64 ~arm64 ppc64 x86"
+IUSE="test"
+
+CDEPEND=">=dev-java/commons-logging-1.1.1:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ app-arch/unzip
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+JAVA_SRC_DIR="src/main/java"
+JAVA_GENTOO_CLASSPATH="commons-logging"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README.txt
+}
+
+src_test() {
+ local DIR=src/test/java
+ local CP="${DIR}:${PN}.jar:$(java-pkg_getjars junit-4,${JAVA_GENTOO_CLASSPATH})"
+ local TESTS=$(find ${DIR} -name "*Test.java")
+ TESTS="${TESTS//src\/test\/java\/}"
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}
diff --git a/dev-java/fontbox/metadata.xml b/dev-java/fontbox/metadata.xml
new file mode 100644
index 000000000000..86f1da025abd
--- /dev/null
+++ b/dev-java/fontbox/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription lang="en">
+ FontBox is a Java font library used to obtain low level information
+ from font files.
+ </longdescription>
+ <longdescription lang="fi">
+ FontBox on Java-kirjasto alhaisen tason tiedon noutamiseen fontti-
+ tiedostoista.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">apache/pdfbox</remote-id>
+ </upstream>
+</pkgmetadata>