summaryrefslogtreecommitdiff
path: root/dev-java/findbugs-annotations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-java/findbugs-annotations
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-java/findbugs-annotations')
-rw-r--r--dev-java/findbugs-annotations/Manifest3
-rw-r--r--dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild41
-rw-r--r--dev-java/findbugs-annotations/metadata.xml7
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/findbugs-annotations/Manifest b/dev-java/findbugs-annotations/Manifest
new file mode 100644
index 000000000000..e7c612858d57
--- /dev/null
+++ b/dev-java/findbugs-annotations/Manifest
@@ -0,0 +1,3 @@
+DIST findbugs-annotations-3.0.1-sources.jar 25170 BLAKE2B aebd9acccae5d4fe209aa9393fb35868a67096889375eab5817eeb6b6cabe950e1a3479826c921254fa1faeaaa8231095b5ef88dc2f83fa3b6ca2a76a1572b42 SHA512 bf77991bcbad1dd3e072c65df36d7714cf2f2967a01ed9e8435b6b40c925d905fc879c83303a227cffa5c3db4c960c9c6813ebb520f5d1c0f178f27710075d43
+EBUILD findbugs-annotations-3.0.1.ebuild 1125 BLAKE2B 137c3f4b5ba506cedafd0f42a8d91250544d17c1f0ee8af0d89264596766abea6fc70d237d919d22f8e68098836db1bd83c66137d17d8923b5adfead499c9a2d SHA512 6bab9193745e4811ba8c5334adc7614c2bc70fe148ce3eb6733e8d1252b9cca91528b501b299f429e21fc7a2779a23d4a1ffcee57e179725f9a6f3a63367c09b
+MISC metadata.xml 217 BLAKE2B cb41a7bd7e5c55319465d67551eae75371cc72d58629c61f70a7f54c388645d5ab1427c66dfdd5954e36ca40f0d3209f871d476cacd61516dd57e3297aaa601f SHA512 4df8395dcf07c52adadee71ad7dfa9f611ade8485cc9869397d0037272ae9add9b40d90669da8b80e578b4ee14c512da01ba096abe39a5859ac71c5316e425b6
diff --git a/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild b/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild
new file mode 100644
index 000000000000..22b9af5b27f8
--- /dev/null
+++ b/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom findbugs-annotations-3.0.1.pom --download-uri https://repo1.maven.org/maven2/com/google/code/findbugs/findbugs-annotations/3.0.1/findbugs-annotations-3.0.1-sources.jar --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild findbugs-annotations-3.0.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.google.code.findbugs:findbugs-annotations:3.0.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Annotation defined by the FindBugs tool"
+HOMEPAGE="http://findbugs.sourceforge.net/"
+SRC_URI="https://repo1.maven.org/maven2/com/google/code/findbugs/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: ${P}.pom
+# com.google.code.findbugs:jsr305:3.0.1 -> >=dev-java/jsr305-3.0.2:0
+
+CP_DEPEND="
+ >=dev-java/jsr305-3.0.2:0
+"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CP_DEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
diff --git a/dev-java/findbugs-annotations/metadata.xml b/dev-java/findbugs-annotations/metadata.xml
new file mode 100644
index 000000000000..75321cfb5598
--- /dev/null
+++ b/dev-java/findbugs-annotations/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>