summaryrefslogtreecommitdiff
path: root/dev-java/ehcache/ehcache-1.2.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/ehcache/ehcache-1.2.4-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/ehcache/ehcache-1.2.4-r3.ebuild')
-rw-r--r--dev-java/ehcache/ehcache-1.2.4-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/ehcache/ehcache-1.2.4-r3.ebuild b/dev-java/ehcache/ehcache-1.2.4-r3.ebuild
new file mode 100644
index 000000000000..ca21347361af
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.2.4-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-2.0"
+SLOT="1.2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-java/commons-collections:0
+ dev-java/commons-logging:0
+ java-virtuals/servlet-api:2.4"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+JAVA_SRC_DIR="src"
+
+JAVA_GENTOO_CLASSPATH="commons-collections,commons-logging,servlet-api-2.4"
+
+java_prepare() {
+ unzip -d src ${P}-sources.jar || die
+ rm -rf src/net/sf/ehcache/hibernate || die
+ rm *.jar || die
+}