summaryrefslogtreecommitdiff
path: root/dev-java/edtftpj
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/edtftpj
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/edtftpj')
-rw-r--r--dev-java/edtftpj/Manifest3
-rw-r--r--dev-java/edtftpj/edtftpj-2.4.0.ebuild48
-rw-r--r--dev-java/edtftpj/metadata.xml19
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-java/edtftpj/Manifest b/dev-java/edtftpj/Manifest
new file mode 100644
index 000000000000..7738ddb2259d
--- /dev/null
+++ b/dev-java/edtftpj/Manifest
@@ -0,0 +1,3 @@
+DIST edtftpj-2.4.0.zip 1592179 BLAKE2B 5e0a4df5b220febedc667d5c3c644a0380b57424c0f6d63d2ae72e33a30e75487df378ceed813456bdc8cef1f50584d83de8d7f4fc4d39cf74049accf0a12448 SHA512 bbcbb35805bd84e76fe15f9b07fb984782cd5838b94ee90af336991f0dfdb9b06028a35614a9accf16eb55151f09501cec5fac41030f847a32a679f9404808b0
+EBUILD edtftpj-2.4.0.ebuild 1103 BLAKE2B 7518d994ff16c763a8f09e239af84e3588efb2fdf67734a4b0bfe58d991ef452d5752401a705dfc1a77d572adea129e45f3ae809dbc2eaef0013962d9f049b5a SHA512 4e5a2f7061e50adda782bfed04c8420c93143019551302a55d9bb0fe3c32bac16e531b3037d422ab359c4f03041b334071cadb97312a82392a0c0edfd855c39c
+MISC metadata.xml 808 BLAKE2B f5a754aacac7c94a462c8ce916028df688a188060a879ea333c61327fe1d5395901f9a0dd65b0e3ea78e8c918dab4e96c129807c08ae5b5c11f1119165a74cd5 SHA512 c256394780ef9ac1e7e2639f4ff4c6780e2059188a4ce1fa8250bcb2c7b12963f7e40c511ade1256955221d8f4ba9fb6122cfee279167ece17873dce394c9c91
diff --git a/dev-java/edtftpj/edtftpj-2.4.0.ebuild b/dev-java/edtftpj/edtftpj-2.4.0.ebuild
new file mode 100644
index 000000000000..9dd3acc178cc
--- /dev/null
+++ b/dev-java/edtftpj/edtftpj-2.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="FTP client library written in Java"
+SRC_URI="https://www.enterprisedt.com/products/edtftpj/download/${P}.zip"
+HOMEPAGE="https://enterprisedt.com/products/edtftpnet"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.7"
+
+EANT_DOC_TARGET="javadocs"
+EANT_BUILD_XML="src/build.xml"
+
+java_prepare() {
+ java-pkg_clean
+
+ # Tests are geared for Windows and sit in the main sources.
+ rm -rv src/com/enterprisedt/net/ftp/test || die
+
+ # Delete Windows .bat files.
+ find -name "*.bat" -delete || die
+
+ # Adjust doc URLs to match our layout.
+ find examples -name "*.html" -exec sed -i 's:/doc/manual/:/manual/:g' {} + || die
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+
+ use doc && java-pkg_dojavadoc build/doc/api
+ use source && java-pkg_dosrc src/*
+
+ docinto html
+ use doc && dodoc -r doc/manual
+ use examples && dodoc -r examples
+}
diff --git a/dev-java/edtftpj/metadata.xml b/dev-java/edtftpj/metadata.xml
new file mode 100644
index 000000000000..1259eb23b982
--- /dev/null
+++ b/dev-java/edtftpj/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>
+ edtFTPj is the first choice of Java developers worldwide
+ for incorporating FTP functionality into their applications.
+ edtFTPj is Open Source, licensed under the LGPL, the GNU
+ Lesser General Public License. This means you can freely
+ embed edtFTPj into your commercial Java applications,
+ subject to the normal LGPL restrictions. Unrestricted
+ (non-GPL) source licenses can be also be purchased. edtFTPj
+ has been downloaded over 100,000 times since its first
+ release, and is in use in thousands of companies worldwide.
+ </longdescription>
+</pkgmetadata>