summaryrefslogtreecommitdiff
path: root/dev-java/edtftpj/edtftpj-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/edtftpj/edtftpj-2.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/edtftpj/edtftpj-2.4.0.ebuild')
-rw-r--r--dev-java/edtftpj/edtftpj-2.4.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/edtftpj/edtftpj-2.4.0.ebuild b/dev-java/edtftpj/edtftpj-2.4.0.ebuild
new file mode 100644
index 000000000000..098918ea822c
--- /dev/null
+++ b/dev-java/edtftpj/edtftpj-2.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="FTP client library written in Java"
+SRC_URI="http://www.enterprisedt.com/products/edtftpj/download/${P}.zip"
+HOMEPAGE="http://enterprisedt.com/products/edtftpnet"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND=">=virtual/jdk-1.7
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.7"
+
+EANT_DOC_TARGET="javadocs"
+EANT_BUILD_XML="src/build.xml"
+
+java_prepare() {
+ java-pkg_clean
+
+ # Tests are geared for Windows and sit in the main sources.
+ rm -rv src/com/enterprisedt/net/ftp/test || die
+
+ # Delete Windows .bat files.
+ find -name "*.bat" -delete || die
+
+ # Adjust doc URLs to match our layout.
+ find examples -name "*.html" -exec sed -i 's:/doc/manual/:/manual/:g' {} + || die
+}
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+
+ use doc && java-pkg_dojavadoc build/doc/api
+ use source && java-pkg_dosrc src/*
+
+ docinto html
+ use doc && dodoc -r doc/manual
+ use examples && dodoc -r examples
+}