summaryrefslogtreecommitdiff
path: root/dev-java/edtftpj/edtftpj-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/edtftpj/edtftpj-2.4.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/edtftpj/edtftpj-2.4.0.ebuild')
-rw-r--r--dev-java/edtftpj/edtftpj-2.4.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-java/edtftpj/edtftpj-2.4.0.ebuild b/dev-java/edtftpj/edtftpj-2.4.0.ebuild
deleted file mode 100644
index 9dd3acc178cc..000000000000
--- a/dev-java/edtftpj/edtftpj-2.4.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="FTP client library written in Java"
-SRC_URI="https://www.enterprisedt.com/products/edtftpj/download/${P}.zip"
-HOMEPAGE="https://enterprisedt.com/products/edtftpnet"
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples"
-
-DEPEND=">=virtual/jdk-1.7
- app-arch/unzip"
-
-RDEPEND=">=virtual/jre-1.7"
-
-EANT_DOC_TARGET="javadocs"
-EANT_BUILD_XML="src/build.xml"
-
-java_prepare() {
- java-pkg_clean
-
- # Tests are geared for Windows and sit in the main sources.
- rm -rv src/com/enterprisedt/net/ftp/test || die
-
- # Delete Windows .bat files.
- find -name "*.bat" -delete || die
-
- # Adjust doc URLs to match our layout.
- find examples -name "*.html" -exec sed -i 's:/doc/manual/:/manual/:g' {} + || die
-}
-
-src_install() {
- java-pkg_dojar lib/${PN}.jar
-
- use doc && java-pkg_dojavadoc build/doc/api
- use source && java-pkg_dosrc src/*
-
- docinto html
- use doc && dodoc -r doc/manual
- use examples && dodoc -r examples
-}