summaryrefslogtreecommitdiff
path: root/dev-java/commons-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 14:00:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 14:00:29 +0100
commit40a480a83a10d1718e26a6f4fc54d271c1f13a95 (patch)
treebfe08ce789f69c5862fd8e5d1bc17b22f9f21b86 /dev-java/commons-text
parent2eda3a3b8ebdb3fc8552feb6f49e466d3bc8e88c (diff)
gentoo auto-resync : 20:10:2022 - 14:00:29
Diffstat (limited to 'dev-java/commons-text')
-rw-r--r--dev-java/commons-text/Manifest2
-rw-r--r--dev-java/commons-text/commons-text-1.10.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/commons-text/Manifest b/dev-java/commons-text/Manifest
index 582b5cec8aff..f32e9a2bf82e 100644
--- a/dev-java/commons-text/Manifest
+++ b/dev-java/commons-text/Manifest
@@ -1,3 +1,5 @@
+DIST commons-text-1.10.0-src.tar.gz 342224 BLAKE2B efed282c9fed7dae5766f7158136a4d7414ba0610e16a52fa2d12ee04e43960d47ec7c62f220c2ab881a13afa8a81cf85e453364e37c67550e15c314122ebf25 SHA512 6bf2dc7dda4429cb1b9ba3a4d383c1d9ffabd5ff35a0adc55216e7cf4c532e51b2b012c9b0f3ea859cd32aef75e05547d892301f34f304a0bfd27c39a28fe04f
DIST commons-text-1.9-sources.tar.gz 312764 BLAKE2B 44b628c418a910ff38b5a1fb3b4c9f14a1f9818afd12540f8c8cf8b1a99fd7abd365e704142bcec901e5e067b303ff44f9c992f8714eae68b94819780a270dd2 SHA512 53f993e79aaa6789d3388aa96b6b2a14cf646b27ff3774524390e511241a85288947cc929519eff61a8734578f25bdf3d9969d84da20c1a749b19d90a55da8ae
+EBUILD commons-text-1.10.0.ebuild 1947 BLAKE2B 379545f1aba4a3d431a0119db4136edf8d29fd91ab15b41c774df7483025e2b3861fc0d143ae65ce577c84db4cc476f3fb3a96b53b56d56bea26b2818b69c1ed SHA512 566ad770080e2eefe08e9c4f76d66c0b0f4c1097cfd77623854a6f3d472488ccfee7ce6ea9dff4bf39e336c88962f3045bfe6502e0a8c149f0bc4c538e09fe26
EBUILD commons-text-1.9.ebuild 1142 BLAKE2B 0beeef324dac52e6201d090bf55e4d1d090d88d82ccf3a6beaa2b7d1cfb7670295cf294c0c071863583f3512dcd4bf38f24e53f94fa972f1f82e14d9262f947d SHA512 658d2fd0186f9dded92492d975f2262f35c2a618a25dd85a6c2e1d82a4663a7f833703675ad1bedebeae4234fbe90269bf28f61d2c1e2d0bc659faa6ab36a6c1
MISC metadata.xml 237 BLAKE2B 7c3263833976c18611a5cba44845af4d80f2f86c48cf587a657292ed0074022088cef88756e3209b292252dce5c0eea307c4f2f45f28b8517609124708f7d09a SHA512 e8227b536eb45569cbf744907106e101d1aa6bf9ba8337783786d719ab107d8bda0fde5dd7067d168181d694b4161b12d1ef3cb5a83b14971b21aa4479670559
diff --git a/dev-java/commons-text/commons-text-1.10.0.ebuild b/dev-java/commons-text/commons-text-1.10.0.ebuild
new file mode 100644
index 000000000000..49f9e33ed28d
--- /dev/null
+++ b/dev-java/commons-text/commons-text-1.10.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache//commons/text/source/commons-text-1.10.0-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-text-1.10.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.apache.commons:commons-text:1.10.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache Commons Text is a library focused on algorithms working on strings"
+HOMEPAGE="https://commons.apache.org/proper/commons-text/"
+SRC_URI="mirror://apache//commons/text/source/commons-text-${PV}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# org.apache.commons:commons-lang3:3.12.0 -> >=dev-java/commons-lang-3.12.0:3.6
+
+CDEPEND="
+ dev-java/commons-lang:3.6
+"
+
+# Compile dependencies
+# POM: pom.xml
+# test? commons-io:commons-io:2.11.0 -> >=dev-java/commons-io-2.11.0:1
+# test? org.apache.commons:commons-rng-simple:1.4 -> !!!artifactId-not-found!!!
+# test? org.assertj:assertj-core:3.23.1 -> !!!suitable-mavenVersion-not-found!!!
+# test? org.graalvm.js:js:22.0.0.2 -> !!!groupId-not-found!!!
+# test? org.graalvm.js:js-scriptengine:22.0.0.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.9.1 -> !!!groupId-not-found!!!
+# test? org.mockito:mockito-inline:4.8.0 -> !!!artifactId-not-found!!!
+# test? org.openjdk.jmh:jmh-core:1.35 -> >=dev-java/jmh-core-1.35:0
+# test? org.openjdk.jmh:jmh-generator-annprocess:1.35 -> !!!artifactId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CDEPEND}"
+
+DOCS=( CONTRIBUTING.md NOTICE.txt README.md RELEASE-NOTES.txt )
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.text"
+JAVA_ENCODING="ISO-8859-1"
+
+JAVA_GENTOO_CLASSPATH="commons-lang-3.6"
+JAVA_SRC_DIR="src/main/java"