summaryrefslogtreecommitdiff
path: root/dev-java/commons-nullanalysis/commons-nullanalysis-1.2.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 13:59:28 +0000
commit1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (patch)
tree2cb5d912afaf290c355b58f8a7334b0e6c5277f0 /dev-java/commons-nullanalysis/commons-nullanalysis-1.2.17.ebuild
parent7819ef4baadbb9171070ce385f7051989fe64e49 (diff)
gentoo auto-resync : 23:12:2022 - 13:59:28
Diffstat (limited to 'dev-java/commons-nullanalysis/commons-nullanalysis-1.2.17.ebuild')
-rw-r--r--dev-java/commons-nullanalysis/commons-nullanalysis-1.2.17.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-java/commons-nullanalysis/commons-nullanalysis-1.2.17.ebuild b/dev-java/commons-nullanalysis/commons-nullanalysis-1.2.17.ebuild
new file mode 100644
index 000000000000..cf6c5a7325f4
--- /dev/null
+++ b/dev-java/commons-nullanalysis/commons-nullanalysis-1.2.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="de.unkrig.commons:commons-nullanalysis:1.2.17"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Annotations and utility classes for ECLIPSE annotation-base null analysis"
+HOMEPAGE="https://unkrig.de/w/Commons.unkrig.de"
+SRC_URI="https://github.com/aunkrig/commons/archive/V${PV}.tar.gz -> unkrig-commons${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/commons-${PV}/commons-nullanalysis"
+
+JAVA_SRC_DIR="src/main/java"