summaryrefslogtreecommitdiff
path: root/dev-java/commons-io
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
commitfc879856a16ea66528a11a00cf6ee19891f3d186 (patch)
tree01ac0b4134970567587e7176ffc531a404898186 /dev-java/commons-io
parentf73bef95b39f4fbc8f0278c26ad1534e5eec322f (diff)
gentoo auto-resync : 24:07:2022 - 20:54:05
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/Manifest1
-rw-r--r--dev-java/commons-io/commons-io-2.11.0-r1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index ac793302e58e..913aaba6063b 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1,3 +1,4 @@
DIST commons-io-2.11.0-sources.tar.gz 498841 BLAKE2B e45ae4400246d7469e8628f08d2f647ea670b994360c1150fe1f414beee5177e7af7c94589a5c81ce6996f2fb755441f29080ca9b69b98cb5ae1ad897f8f00b5 SHA512 e2ab8ebc9c328093a460f8f5f96c80bb45f5073ec7aaa0beabdcdeac2e97324292eab2e2cb8b64d8e78b2c5d89048ba84e50daa0965dffcbe2fd0da7ab789ee3
+EBUILD commons-io-2.11.0-r1.ebuild 1879 BLAKE2B c348641cc0dbd80cf3a080fabe9a1169831ed82cc6a8313db136051c40a1a281f3656ab4549851faa312943f781e4fa5f8bc0319d0691199b3a7bb34476e99c8 SHA512 5a131e0da771c8a7aa1ed6bc32a15e73a79ba5e7ecb4192acfa6dbb37f90a4fb2c0a0d80e9574086e3f74addefa68a76e19beeea812b76899c1891191a3df372
EBUILD commons-io-2.11.0.ebuild 1829 BLAKE2B 9752da4af980cd2a649eb50802af49560f0b1cb2db6ba2716222bf53e1ce7650954accf2c68551034428eb939ada28e406a1320b01045772a158b4b6394b7f8e SHA512 6cf2465163855384be4bb0f542f86fc1efe0c99a13c1d476d871478307c073cc83be815018fa77aa4a0d63fa714b11dc1acc5b6b7e306cc269a582139d790d0a
MISC metadata.xml 233 BLAKE2B 2b385ca77219f08b2874b3a4a91a0c836d3cb45ec44b05babb33d590c56ceb5337ecb93a8450a37f8e6bbf4cfc1455892e8142d22e0a1d527d40361e2dce350b SHA512 1acc975a7dc3344bc63282d652ca00d8245970b58353b4fd00f09a4859db3eaba2dcd85e1537d424b7174e4f9c01c2ffb10ec6d107b5c895c9ca20730666de7f
diff --git a/dev-java/commons-io/commons-io-2.11.0-r1.ebuild b/dev-java/commons-io/commons-io-2.11.0-r1.ebuild
new file mode 100644
index 000000000000..73150451cd28
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.11.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://mirror.dkm.cz/apache//commons/io/source/commons-io-2.11.0-src.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild commons-io-2.11.0.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-io:commons-io:2.11.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utility classes, stream implementations, file filters, and much more"
+HOMEPAGE="https://commons.apache.org/proper/commons-io/"
+SRC_URI="mirror://apache/commons/io/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+# Compile dependencies
+# POM: pom.xml
+# test? com.google.jimfs:jimfs:1.2 -> !!!groupId-not-found!!!
+# test? org.apache.commons:commons-lang3:3.12.0 -> >=dev-java/commons-lang-3.12.0:3.6
+# test? org.junit-pioneer:junit-pioneer:1.4.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.7.2 -> !!!groupId-not-found!!!
+# test? org.mockito:mockito-inline:3.11.2 -> !!!artifactId-not-found!!!
+# test? org.openjdk.jmh:jmh-core:1.32 -> !!!groupId-not-found!!!
+# test? org.openjdk.jmh:jmh-generator-annprocess:1.32 -> !!!groupId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ test? (
+ >=dev-java/commons-lang-3.12.0:3.6
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+# some test dependencies are missing
+RESTRICT="test"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="commons-lang-3.6"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.io"