summaryrefslogtreecommitdiff
path: root/dev-java/commons-io
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-java/commons-io
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/Manifest2
-rw-r--r--dev-java/commons-io/commons-io-2.11.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index d5d84a19e665..1d8f17a28a68 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1,3 +1,5 @@
+DIST commons-io-2.11.0-sources.tar.gz 498841 BLAKE2B e45ae4400246d7469e8628f08d2f647ea670b994360c1150fe1f414beee5177e7af7c94589a5c81ce6996f2fb755441f29080ca9b69b98cb5ae1ad897f8f00b5 SHA512 e2ab8ebc9c328093a460f8f5f96c80bb45f5073ec7aaa0beabdcdeac2e97324292eab2e2cb8b64d8e78b2c5d89048ba84e50daa0965dffcbe2fd0da7ab789ee3
DIST commons-io-2.8.0-sources.tar.gz 445833 BLAKE2B 4fc6f9b66fa88adfc110742bd3eab55cbe165552f71d665f70fd54d4b0b79c4e76b45fccdb78c6ef64e476f54efc8b51adc9b2d7e880c71dbdb6bc5883d2fe55 SHA512 6189c72eff8661bfb8cfed95dd7ee32578b24b50f6586d4628a4dbfd3618853a72eb73da311729e55742ace47b2d38d3ce130ab87b684494d8ce33d1ccf14a2d
+EBUILD commons-io-2.11.0.ebuild 1829 BLAKE2B b884ba97cc1b9f8a79a27138539ffd5ee139b8e4b1e940baf441265817cdc99abd5a17068794805e6142aeb2c2352ac4a52429988a91f94f44f6fef81da97c21 SHA512 961aa16513b7dd03db6b4082bdcff5ffbad7a4df5290f0796acb43e53ee81fe5c2df13f91942be8be6963c08a4f38237d256d9f9a0663a1d85982c5c4b8a7ebf
EBUILD commons-io-2.8.0.ebuild 1031 BLAKE2B eed3f1516b0a4b9382ee69b133363be093018abf28ef84c056f725e904ca78eeac9902aa51210e0ca8ed46dbd11cbe0638d2ef8c6be80dacc938eb4e2f5a8f21 SHA512 7dbaecd92f51898e047efe48fd47c013d6a96ace64f5921307eb0caaff1182c719c5f268a77da1bb09769535e0fbd03ec098bf10900fce1929893f5e46e82a01
MISC metadata.xml 233 BLAKE2B 2b385ca77219f08b2874b3a4a91a0c836d3cb45ec44b05babb33d590c56ceb5337ecb93a8450a37f8e6bbf4cfc1455892e8142d22e0a1d527d40361e2dce350b SHA512 1acc975a7dc3344bc63282d652ca00d8245970b58353b4fd00f09a4859db3eaba2dcd85e1537d424b7174e4f9c01c2ffb10ec6d107b5c895c9ca20730666de7f
diff --git a/dev-java/commons-io/commons-io-2.11.0.ebuild b/dev-java/commons-io/commons-io-2.11.0.ebuild
new file mode 100644
index 000000000000..ef103119de08
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.11.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://mirror.dkm.cz/apache//commons/io/source/commons-io-2.11.0-src.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild commons-io-2.11.0.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="commons-io:commons-io:2.11.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utility classes, stream implementations, file filters, and much more."
+HOMEPAGE="https://commons.apache.org/proper/commons-io/"
+SRC_URI="mirror://apache/commons/io/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+# Compile dependencies
+# POM: pom.xml
+# test? com.google.jimfs:jimfs:1.2 -> !!!groupId-not-found!!!
+# test? org.apache.commons:commons-lang3:3.12.0 -> >=dev-java/commons-lang-3.12.0:3.6
+# test? org.junit-pioneer:junit-pioneer:1.4.2 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter:5.7.2 -> !!!groupId-not-found!!!
+# test? org.mockito:mockito-inline:3.11.2 -> !!!artifactId-not-found!!!
+# test? org.openjdk.jmh:jmh-core:1.32 -> !!!groupId-not-found!!!
+# test? org.openjdk.jmh:jmh-generator-annprocess:1.32 -> !!!groupId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ test? (
+ >=dev-java/commons-lang-3.12.0:3.6
+ )
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+# some test dependencies are missing
+RESTRICT="test"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"
+
+JAVA_TEST_GENTOO_CLASSPATH="commons-lang-3.6"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS=(
+ "src/test/resources"
+)