summaryrefslogtreecommitdiff
path: root/dev-java/commons-io
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/commons-io
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/Manifest4
-rw-r--r--dev-java/commons-io/commons-io-2.4.ebuild58
-rw-r--r--dev-java/commons-io/commons-io-2.8.0.ebuild33
3 files changed, 35 insertions, 60 deletions
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index dc6b6225d127..a48999714011 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1,3 +1,3 @@
-DIST commons-io-2.4-src.tar.gz 330961 BLAKE2B 1a1ae7c968bfc38b4a4f3c4c131de088c4efdd8fff0858e7493e057909076c74d4b0ebee1999ef01af9636d88600ecca71bb0808686a6f9c1a20f4d7a5cbe6e6 SHA512 69ac5f7b8de952d8b519ad89d4e9a33a9d269af0e68b735c0180ee8853a30e2a09147ceac362626a2fb3a041bd46eca094be2661ff280c1bab54a0548cae0aee
-EBUILD commons-io-2.4.ebuild 1571 BLAKE2B db7712b9a8fae484ac0e42053c545cb5ddaf18bece53cb13c24b9c111e2e38a5fc58552b337cf21960600d096db7d98461e7ecae616fad0031e25fa5eba88c6b SHA512 1aee82477b69219e265ebffc9e9e78f892852d7eeedf47a98a6bc7b0803cc5ae1f038d9a7318d16e7efbbd3a60ac3ab29b6cc57e66bf9710480ff73620418a6e
+DIST commons-io-2.8.0-sources.tar.gz 445833 BLAKE2B 4fc6f9b66fa88adfc110742bd3eab55cbe165552f71d665f70fd54d4b0b79c4e76b45fccdb78c6ef64e476f54efc8b51adc9b2d7e880c71dbdb6bc5883d2fe55 SHA512 6189c72eff8661bfb8cfed95dd7ee32578b24b50f6586d4628a4dbfd3618853a72eb73da311729e55742ace47b2d38d3ce130ab87b684494d8ce33d1ccf14a2d
+EBUILD commons-io-2.8.0.ebuild 1032 BLAKE2B db544b790131b095e00e2966a7633a949e71f32d75545e02491bd0bf59e9ee7a49854dc6d98422167b02fe62d45a84ceff51970c53f62ff40e5f08316d410777 SHA512 a4b5f9b49eb8729afee00b0b29eeb14b5bc15f0f0ffd28da7241fa44335070d0ce7a078159dfdd69553710e82ada47ed947ff71f616dd25913fe01fc9c34cdf6
MISC metadata.xml 232 BLAKE2B 513679b02247d8e4cb4c874abd785119d9ca62ad24c44969d52a42c3765d0ebf689024512a2c4c48e69688a4ce02a74ae05708b050a720bc73d8d2bf2ceff58d SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893
diff --git a/dev-java/commons-io/commons-io-2.4.ebuild b/dev-java/commons-io/commons-io-2.4.ebuild
deleted file mode 100644
index 6b4ce6ef64d4..000000000000
--- a/dev-java/commons-io/commons-io-2.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2 eutils
-
-MY_P=${P}-src
-DESCRIPTION="Utility classes, stream implementations, file filters, and endian classes"
-HOMEPAGE="http://commons.apache.org/io/"
-SRC_URI="mirror://apache/commons/io/source/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S=${WORKDIR}/${MY_P}
-
-EANT_EXTRA_ARGS="-Dcomponent.version=${PV}"
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-JAVA_ANT_ENCODING="ISO-8859-1"
-
-java_prepare() {
- # Setting java.io.tmpdir doesn't have effect unless we do this because the vm is forked
- java-ant_xml-rewrite -f build.xml --change -e junit -a clonevm -v "true"
-}
-
-src_test() {
- if [[ ${EUID} -ne 0 ]] ; then
- ANT_OPTS="-Dskip.download=1 -Djava.io.tmpdir=${T} -Duser.home=${T}" \
- ANT_TASKS="ant-junit" \
- eant test \
- -Dgentoo.classpath="$(java-pkg_getjars junit-4):${S}/src/test/resources" \
- -Dlibdir="libdir" \
- -Djava.io.tmpdir="${T}"
- else
- elog "Tests fail unless userpriv is enabled because they test for"
- elog "file permissions which doesn't work when run as root."
- fi
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar
-
- dodoc RELEASE-NOTES.txt
- use doc && java-pkg_dojavadoc target/apidocs
- use source && java-pkg_dosrc src/main/java/*
-}
diff --git a/dev-java/commons-io/commons-io-2.8.0.ebuild b/dev-java/commons-io/commons-io-2.8.0.ebuild
new file mode 100644
index 000000000000..6b1a3a17f7b6
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://ftp.fau.de/apache//commons/io/source/commons-io-2.8.0-src.tar.gz --slot 1 --keywords "~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris" --ebuild commons-io-2.8.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="commons-io:commons-io:2.8.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utility classes, stream implementations, file filters, and endian classes"
+HOMEPAGE="https://commons.apache.org/proper/commons-io/"
+SRC_URI="mirror://apache/commons/io/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+
+JAVA_SRC_DIR="src/main/java"