summaryrefslogtreecommitdiff
path: root/dev-java/commons-el/commons-el-1.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/commons-el/commons-el-1.0-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-el/commons-el-1.0-r3.ebuild')
-rw-r--r--dev-java/commons-el/commons-el-1.0-r3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/commons-el/commons-el-1.0-r3.ebuild b/dev-java/commons-el/commons-el-1.0-r3.ebuild
new file mode 100644
index 000000000000..a7b3d71f48c2
--- /dev/null
+++ b/dev-java/commons-el/commons-el-1.0-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="EL is the JSP 2.0 Expression Language Interpreter from Apache"
+HOMEPAGE="http://commons.apache.org/el/"
+SRC_URI="mirror://apache/jakarta/commons/el/source/${P}-src.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+COMMON_DEP="
+ java-virtuals/servlet-api:2.5"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4"
+
+S=${WORKDIR}/${P}-src
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-java-1.7-compiler.patch # BGO 486376
+ # Build.xml is broken, fix it
+ sed -i "s:../LICENSE:./LICENSE.txt:" build.xml || die "sed failed"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_GENTOO_CLASSPATH="servlet-api-2.5"
+EANT_EXTRA_ARGS="
+ -Dservletapi.build.notrequired=true
+ -Djspapi.build.notrequired=true"
+
+src_install() {
+ java-osgi_dojar-fromfile "dist/${PN}.jar" "${FILESDIR}/${P}-manifest" \
+ "Apache Commons EL"
+
+ dodoc LICENSE.txt RELEASE-NOTES.txt
+ dohtml STATUS.html PROPOSAL.html
+
+ use source && java-pkg_dosrc src/java/org
+}